This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 243188 - mkbootdisk does not produce bootable Xen image
mkbootdisk does not produce bootable Xen image
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkbootdisk (Show other bugs)
5.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 15:26 EDT by Jari Turkia
Modified: 2010-12-22 09:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-22 09:05:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mkbootdisk.diff (2.34 KB, patch)
2007-06-07 15:26 EDT, Jari Turkia
no flags Details | Diff

  None (edit)
Description Jari Turkia 2007-06-07 15:26:22 EDT
Description of problem:
RHEL5 mkbootdisk does not produce bootable image if kernel-xen is used.

Version-Release number of selected component (if applicable):
mkbootdisk-1.5.3-2.1

How reproducible:
always

Steps to Reproduce:
1. execute /sbin/mkbootdisk --device boot.iso -v --iso 2.6.18-8.1.4.el5xen
2. write boot.iso to a CD
3. attempt booting, it will fail

Patch:
Attached file is a patch to add a new command-line switch --xen. Using this
switch produces a working boot image with kernel-xen.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jari Turkia 2007-06-07 15:26:22 EDT
Created attachment 156497 [details]
mkbootdisk.diff
Comment 2 Stepan Kasal 2009-01-08 07:08:59 EST
Filed for rawhide as well, bug #479246
Comment 3 RHEL Product and Program Management 2009-03-26 12:48:43 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 RHEL Product and Program Management 2010-08-09 14:24:02 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2010-12-22 09:05:27 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.