Bug 243191 - Xen kdump function not enabled
Xen kdump function not enabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-kdump (Show other bugs)
5.0
All Linux
high Severity medium
: ---
: ---
Assigned To: David Lehman
: Reopened
Depends On:
Blocks: 212843 222082 243931
  Show dependency treegraph
 
Reported: 2007-06-07 15:39 EDT by Stephen Tweedie
Modified: 2010-03-14 17:32 EDT (History)
12 users (show)

See Also:
Fixed In Version: RHEA-2007-0882
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:59:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
s-c-kdump support for configuring kdump on xen kernels (6.03 KB, patch)
2007-08-24 12:41 EDT, Jarod Wilson
no flags Details | Diff

  None (edit)
Comment 2 RHEL Product and Program Management 2007-06-07 15:44:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 7 Stephen Tweedie 2007-06-12 15:16:56 EDT
One other detail: not only will system-config-kdump need to enable setup for
Xen, it will also need to make sure it's the _right_ setup, which isn't
precisely the same as for non-xen kernels.

In particular, the "crashkernel=" arg needs to be on the "kernel xen.gz..." line
in the grub.conf, not the "module vmlinuz..." line; and the dump kernel will
need to be loaded "@32m", not the default "@16m" that non-xen uses.
Comment 8 Jarod Wilson 2007-06-14 11:50:23 EDT
nb: I had to deal with the same issue in the firstboot module, and its fairly
straight-forward. We obviously set the offset to 32 instead of 16 on x86 and
x86_64 xen, and then just use grubby with --mbargs instead of --args to add the
parameters to the correct line in grub. These changes are in the latest
kexec-tools (which carries the firstboot module). Not sure yet how this will all
shake out if/when we get around to ia64 xen kdump...
Comment 9 Pete Graner 2007-08-15 16:57:18 EDT
Not an approved component moving to 5.2 for consideration
Comment 10 Jarod Wilson 2007-08-15 16:59:35 EDT
This is in support of a feature add we've committed to for 5.1 though...
Comment 21 Jarod Wilson 2007-08-24 12:41:43 EDT
Created attachment 172434 [details]
s-c-kdump support for configuring kdump on xen kernels

The attached patch implements system-config-kdump xen dump support, bringing it
on par with what we have in the kdump firstboot module.
Comment 28 errata-xmlrpc 2007-11-07 12:59:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0882.html

Note You need to log in before you can comment on or make changes to this bug.