Bug 243223 - Network hangs with Intel 82563EB NIC
Summary: Network hangs with Intel 82563EB NIC
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.5
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
: ---
Assignee: Andy Gospodarek
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-08 00:00 UTC by Joshua Baker-LePain
Modified: 2014-06-29 22:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 22:23:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Baker-LePain 2007-06-08 00:00:55 UTC
Description of problem:
I have 6 dual Xeon 5160 compute nodes with Supermicro X7DVL-E motherboards
<http://www.supermicro.com/products/motherboard/Xeon1333/5000V/X7DVL-E.cfm>.
These boards have onboard Intel 82563EB NICs (PCI ID 8086:1096).  When I first
installed them, I was running U4 (kernel 2.6.9-42.0.x), which included version
e1000-7.0.39.  The network interfaces were very unreliable -- they would
randomly stop and then re-start passing traffic.  I downloaded version
e1000-7.3.20 from intel.com, and they worked just fine.

With the release of U5 (kernel 2.6.9-55) and its inclusion of e1000-7.2.7, I
decided to give the stock driver a try again, but it had the same issues. 
Again, upgrading to a more recent version from intel.com (e1000-7.5.5 in this
case) fixed the problem.

Version-Release number of selected component (if applicable):
kernel 2.6.9-55
e1000 7.2.7

How reproducible:
Every time.

Steps to Reproduce:
1. Install kernel 2.6.9-55
  
Actual results:
Network is highly unreliable (df hangs on NFS shares, can't do YP lookups, etc)

Expected results:
Reliable network.

Additional info:
According to my server vendor, this problem still exists in RHEL5 (which also
uses e1000-7.2.7).

Comment 1 Andy Gospodarek 2007-09-17 19:46:10 UTC
A major update to e1000 is planned for the next update.

You can always try my latest test kernels (they generally contain experimental
net-driver fixes and are regularly updated):

http://people.redhat.com/agospoda/#rhel4

For this case, you can also check the kernels available here:

http://people.redhat.com/jbaron/rhel4/

Since they contain kernels that are close to the ones that will be released with
the next RHEL4 update.

Can you give either of those 2 kernels a try?


Comment 2 Joshua Baker-LePain 2007-09-21 04:27:07 UTC
Since filing this bug I've switched jobs and moved across the country, although
I do still consult for that group.  I'll try to give those kernels a shot ASAP.
 Given the driver version is one I've had work, I'm hopeful.

Thanks.

Comment 3 Andy Gospodarek 2008-04-07 22:23:29 UTC
This bug has seen no activity in quite a while, so I can only presume it is no
longer a problem.  If there is still an issue that needs to be resolved, please
re-open this bug and I will be happy to help resolve it.  Thank you.


Note You need to log in before you can comment on or make changes to this bug.