Bug 243225 - Thunderbird interface in Simplified Chinese on zh_TW locale.
Summary: Thunderbird interface in Simplified Chinese on zh_TW locale.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird   
(Show other bugs)
Version: 7
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Keywords: i18n, Reopened
Depends On:
Blocks: 227464
TreeView+ depends on / blocked
 
Reported: 2007-06-08 00:40 UTC by Caius Chance
Modified: 2009-09-21 20:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 03:04:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Caius Chance 2007-06-08 00:40:21 UTC
Description of problem:
Thunderbird interface in Simplified Chinese on zh_TW locale.

Version-Release number of selected component (if applicable):
FC5 latest thunderbird package.

How reproducible:
Always.

Steps to Reproduce:
1. Start gnome desktop.
2. Open vitrual console: Alt-F2 -> 'gnome-terminal'.
3. Input in console: 'LANG=zh_TW.UTF-8 thunderbird'.
  
Actual results:
Thunderbird has Simplified Chinese interface.

Expected results:
Thunderbird has Tradirional Chinese interface.

Additional info:
- Thunderbird already has Traditional Chinese from upstream -
http://www.mozilla.com/en-US/thunderbird/all-older.html
- TC had been supported since 1.0.x.

Comment 1 Jens Petersen 2007-06-08 06:17:31 UTC
The zh_TW langpack is included but presumably is using Simplified Chinese. :-(

Comment 2 Christopher Aillon 2007-06-08 06:54:58 UTC
This bug is filed against FC5.  Please test against FC7.

Comment 3 Jens Petersen 2007-06-08 07:14:12 UTC
We tested F7 and the problem is (still) there.

Comment 4 Parag Nemade 2007-10-01 11:10:27 UTC
Though I don't know Chinese but what I saw with visual comparison is that I got
different output with thunderbird version 0:2.0.0.6-5.fc8 (and with
0:2.0.0.5-2.fc7) when I check output of 
LANG=zh_CN.UTF-8 thunderbird
and
LANG=zh_TW.UTF-8 thunderbird

Cchance,
 Can you confirm whether this bug exists in rawhide or with F7 system with
updates installed ?

Comment 5 Caius Chance 2007-10-01 23:43:57 UTC
Tested on F7 with updates and rawhide (thunderbird-2.0.0.6-5), they both works
correctly.

Comment 6 Tina 2007-10-02 03:30:02 UTC
I just checked thunderbird on my f7 machine. The interface is in Traditional
Chinese. But noted that my thunderbird is thunderbird-2.0.0.5-1.fc7, not
0:2.0.0.6-5.fc8 (and with 0:2.0.0.5-2.fc7) . 

Comment 7 Christopher Aillon 2007-10-03 18:43:42 UTC
So this is fixed?

Comment 8 Caius Chance 2007-10-03 23:49:23 UTC
Works for me (with latest ver).

Comment 9 Parag Nemade 2007-10-04 03:53:42 UTC
thanks cchance for testing this.


Note You need to log in before you can comment on or make changes to this bug.