Bug 243231 - Cairo slideshow is too slow, nvidia drivers, i810 drivers
Summary: Cairo slideshow is too slow, nvidia drivers, i810 drivers
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-08 04:01 UTC by The Source
Modified: 2008-04-18 12:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 12:36:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Presentation slowdown example (1.72 MB, application/vnd.ms-powerpoint)
2007-06-08 04:01 UTC, The Source
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 69548 None None None Never
OpenOffice.org 88103 None None None Never

Description The Source 2007-06-08 04:01:00 UTC
Description of problem:
Presentation attached is shown too slow. And I have Core 2 Duo 2.4GHz processor
and GeForce 8800 GTX with drivers from NVIDIA! And by the way it does not go on
to the next slide automatically. And if I click to force it, music stops.

Version-Release number of selected component (if applicable):
openoffice.org-impress-2.2.0-14.8

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 The Source 2007-06-08 04:01:01 UTC
Created attachment 156543 [details]
Presentation slowdown example

Comment 2 Caolan McNamara 2007-06-08 07:28:35 UTC
Seems to work at a fine speed for me with a 6800 GS and the nv driver.

Does toggling tools->options->openoffice.org->view->use hardware acceleration to
off make a difference in speed for you ?

Comment 3 The Source 2007-06-08 17:45:08 UTC
Without "use hardware" option slide show is much faster. But presentation should
go on automatically and it does not. (perhaps it is separate bug). My nvidia
driver version is 100.14.06 by the way.

Comment 4 Caolan McNamara 2007-06-08 18:08:13 UTC
Well, now we have a problem, these are the nvidia drivers so we can't fix them :-(
But looking at
http://http.download.nvidia.com/XFree86/Linux-x86/1.0-8178/README/appendix-d.html
I would expect that toggling "RenderAccel" may make a difference here, if there
is no RenderAccel line in your xorg.conf try adding one that says true to the
appropiate section, otherwise toggle from false to true or vice versa. Does that
have any effect ?

The additional problem re not changing slides automatically sounds like a
generic ppt import problem, I suggest you submit that to openoffice.org's
issuezilla. I don't have powerpoint to hand to compare the two unfortunately.

Comment 5 The Source 2007-06-08 19:04:00 UTC
RenderAccel is enabled by default. I added this option to xorg.conf just in case
but as I thought it changed nothing.

Comment 6 The Source 2007-06-09 08:29:31 UTC
You know what? The problem is not in the nvidia drivers. I use i810 module on my
work computer and the situation is the same: without "use hardware" option slide
show is much faster.

Comment 7 Caolan McNamara 2007-06-09 08:52:42 UTC
caolanm->cworth: FYI, cairo sucks :-)

Comment 8 Caolan McNamara 2008-04-18 12:36:43 UTC
The outstanding part of this is upstreamed as
http://www.openoffice.org/issues/show_bug.cgi?id=88103


Note You need to log in before you can comment on or make changes to this bug.