Bug 243383 - Package should require yelp for its help
Summary: Package should require yelp for its help
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glabels
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-08 16:25 UTC by Matěj Cepl
Modified: 2018-04-11 11:07 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-07-08 20:55:25 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2007-06-08 16:25:42 UTC
This package uses yelp for its help. Therefore, it should require package yelp for its operation.

[Filed by a script; forgive him if he made a mistake for once.]

Comment 1 Peter Gordon 2007-06-09 04:21:33 UTC
Thanks for the catch. I plan to bump it to the 2.1 development series Real Soon
Now(TM), so I'll fix this at that time.

Comment 2 Christopher Aillon 2007-06-09 22:50:47 UTC
All of these bug reports are (most likely) wrong.  The package should NOT
require yelp.  We went through effort to ensure that yelp is not a requirement
for the desktop.

You should ask yourself: will the package fail to work if yelp is not installed?
 If not, do not require yelp.

If you have already committed this fix blindly, I ask that you consider undoing
it so derivative projects can continue using your package without help if they
so choose.

We have added yelp to the default install via comps so that all installs get
yelp by default unless they specifically ask for it to be removed.  We should
honor that.  Please undo your changes if you have made them and/or mark this bug
WONTFIX.  Thanks.

Comment 3 Hans de Goede 2007-07-08 10:12:45 UTC
Peter,

Whats the status of this? As explained in comment #2, this bug is erroneous,
please do not add the Requires, and if you have remove it. If you haven't added
the Requires yet, please close this bug. If you have close it once removed.



Comment 4 Peter Gordon 2007-07-08 20:55:25 UTC
Oopsie. Thanks for the poke, Hans. I've removed it from the spec after being
notified of the error, so will close this bug as NOTABUG now.


Note You need to log in before you can comment on or make changes to this bug.