Bug 243387 - Package should require yelp for its help
Package should require yelp for its help
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnochm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 12:26 EDT by Matěj Cepl
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.10-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 15:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2007-06-08 12:26:07 EDT
This package uses yelp for its help. Therefore, it should require package yelp for its operation.

[Filed by a script; forgive him if he made a mistake for once.]
Comment 1 Christopher Aillon 2007-06-09 18:51:01 EDT
All of these bug reports are (most likely) wrong.  The package should NOT
require yelp.  We went through effort to ensure that yelp is not a requirement
for the desktop.

You should ask yourself: will the package fail to work if yelp is not installed?
 If not, do not require yelp.

If you have already committed this fix blindly, I ask that you consider undoing
it so derivative projects can continue using your package without help if they
so choose.

We have added yelp to the default install via comps so that all installs get
yelp by default unless they specifically ask for it to be removed.  We should
honor that.  Please undo your changes if you have made them and/or mark this bug
WONTFIX.  Thanks.
Comment 2 Patrice Dumas 2007-06-10 05:49:37 EDT
(In reply to comment #1)

> You should ask yourself: will the package fail to work if yelp is not installed?
>  If not, do not require yelp.

Depends on what working means. Of course it is only needed for the
help. When I click on the help button in the interface nothing happens 
if yelp isn't installed. And on the console I get, quite logically:

Traceback (most recent call last):
  File "/usr/bin/gnochm", line 1565, in on_contents_activate
    gnome.help_display(path_help, 'index')
gobject.GError: There was an error launching the default action command
associated with this location.

So it isn't plain obvious that it isn't needed. From the user
perspective having help system working seems to be better to
me. 

Seems that yelp requires only the usual gnome stuff, and 
firefox. So it doesn't seems to me to be really problematic
to bring in yelp. Maybe it would be better for yelp not to require
firefox itself, but a renderer engine, but that's not an issue
for gnochm.
 
> If you have already committed this fix blindly, I ask that you consider undoing

I try to avoid doing things blindly.

> it so derivative projects can continue using your package without help if they
> so choose.

In that case they can still remove the Requires.

> We have added yelp to the default install via comps so that all installs get
> yelp by default unless they specifically ask for it to be removed.  We should
> honor that.  Please undo your changes if you have made them and/or mark this bug
> WONTFIX.  Thanks.

comps is irrelevant, the Requires and comps don't embed the same 
information.


In my opinion, if you want project that use yelp not to require
it you should come with  guideline, otherwise it should certainly
be left to the packagers.

Note You need to log in before you can comment on or make changes to this bug.