Bug 243451 - activation key package install reports multiple listings of the same package after pkg install
activation key package install reports multiple listings of the same package ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 15:21 EDT by wes hayutin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0815
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:34:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up2date's log (132.07 KB, text/plain)
2007-08-28 07:36 EDT, Michal Nowak
no flags Details

  None (edit)
Description wes hayutin 2007-06-08 15:21:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070221 Red Hat/1.5.0.10-0.1.el4 Firefox/1.5.0.10

Description of problem:
Description of problem:
activation key package install reports multiple listings of the same package after pkg install

an example is below..
[root@fjs-0-06 root]# rhnreg_ks   --serverUrl=http://xmlrpc.rhn.webqa.redhat.com/XMLRPC --force --activationkey=d1666925f912122e99352134f84f0f3c --profile=westest01

Name                                    Version        Rel
----------------------------------------------------------


The following packages you requested are already updated:
bash
bash
bash
bash
bash
screen
zsh
zsh

bash and zsh should only have one entry.

recreate..
1 create an activation key w/ the above packages in the package list.
2 run the registration w/ the activation key
3. notice the packages are installed.
4. run the registration one more time and you will get the same out put as above


Version-Release number of selected component (if applicable):
up2date-4.5.5-8.el3

How reproducible:
Always


Steps to Reproduce:
1 create an activation key w/ the above packages in the package list.
2 run the registration w/ the activation key
3. notice the packages are installed.
4. run the registration one more time and you will get the same out put as above


Actual Results:
The following packages you requested are already updated:
bash
bash
bash
bash
bash
screen
zsh
zsh


Expected Results:
The following packages you requested are already updated:
bash
screen
zsh



Additional info:
Comment 1 RHEL Product and Program Management 2007-06-14 17:14:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Pradeep Kilambi 2007-07-27 11:28:55 EDT
seems to be working ok as of up2date-4.5.5-7.el4

[root@rlx-2-22 ~]# rhnreg_ks  
--serverUrl=http://rlx-0-22.rhndev.redhat.com/XMLRPC --force
--activationkey=b9cf87711623aaf5db7d8be91c12af91
[]

Name                                    Version        Rel     
----------------------------------------------------------


The following packages you requested are already updated:
screen
zsh


please re test in qa and let me know if you see any more issues.
Comment 3 Pradeep Kilambi 2007-08-01 15:33:21 EDT
still happens in some cases on up2date-4.5.5-7.el4

fixed now
Committed revision 118790.
Comment 5 Michal Nowak 2007-08-28 07:35:34 EDT
I still got similar tracebacks in 4.5.5 and 4.6.2 version:

[root@proliant04 rhn]# rpmquery up2date
up2date-4.5.5-7.el4

[root@proliant04 rhn]# rhnreg_ks 
--serverUrl=http://rlx-0-22.rhndev.redhat.com/XMLRPC
--activationkey=b9cf87711623aaf5db7d8be91c12af91 --force

Name                                    Version        Rel     
----------------------------------------------------------
screen                                  4.0.3          1.el5             i386  
No advisory information available

zsh                                     4.2.6          1                 i386  
No advisory information available


warning: package glibc = 2.5-12 was already added, replacing with glibc <= 2.5-12
warning: package openssl = 0.9.8b-8.3.el5 was already added, replacing with
openssl <= 0.9.8b-8.3.el5
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 345, in ?
    handle_action(action)
  File "/usr/sbin/rhn_check", line 218, in handle_action
    (status, message, data) = run_action(method, params)
  File "/usr/sbin/rhn_check", line 174, in run_action
    (status, message, data) = do_call(method, params)   
  File "/usr/sbin/rhn_check", line 91, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 353, in update
    ret = _catchErrors(batchRun, "packages.update", (0, pkgList))
  File "/usr/share/rhn/actions/packages.py", line 189, in _catchErrors
    ret = apply(method, args)
  File "/usr/share/rhn/actions/packages.py", line 390, in batchRun
    actionPkgs = pkgList)
  File "/usr/share/rhn/up2date_client/wrapper.py", line 1127, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 83, in run
    self.__dryRun()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 213, in __dryRun
    self.percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 384, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 752, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 646, in process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 409, in __dependencies
    if iPkg[4] == aPkg[4] or iPkg[4] == "noarch" or aPkg[4] == "noarch":
UnboundLocalError: local variable 'iPkg' referenced before assignment

[root@proliant04 rhn]# rpm -Uvh
/mnt/redhat/brewroot/packages/up2date/4.6.2/5.el4/i386/up2date-*
Preparing...                ########################################### [100%]
   1:up2date                ########################################### [ 33%]
   2:up2date-debuginfo      ########################################### [ 67%]
   3:up2date-gnome          ########################################### [100%]
[root@proliant04 rhn]# rhnreg_ks 
--serverUrl=http://rlx-0-22.rhndev.redhat.com/XMLRPC
--activationkey=b9cf87711623aaf5db7d8be91c12af91 --force

Name                                    Version        Rel     
----------------------------------------------------------
screen                                  4.0.3          1.el5             i386  
No advisory information available

zsh                                     4.2.6          1                 i386  
No advisory information available


warning: package glibc = 2.5-12 was already added, replacing with glibc <= 2.5-12
warning: package openssl = 0.9.8b-8.3.el5 was already added, replacing with
openssl <= 0.9.8b-8.3.el5
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 345, in ?
    handle_action(action)
  File "/usr/sbin/rhn_check", line 218, in handle_action
    (status, message, data) = run_action(method, params)
  File "/usr/sbin/rhn_check", line 174, in run_action
    (status, message, data) = do_call(method, params)   
  File "/usr/sbin/rhn_check", line 91, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 353, in update
    ret = _catchErrors(batchRun, "packages.update", (0, pkgList))
  File "/usr/share/rhn/actions/packages.py", line 189, in _catchErrors
    ret = apply(method, args)
  File "/usr/share/rhn/actions/packages.py", line 390, in batchRun
    actionPkgs = pkgList)
  File "/usr/share/rhn/up2date_client/wrapper.py", line 1127, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 83, in run
    self.__dryRun()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 218, in __dryRun
    self.percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 384, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 757, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 651, in process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 415, in __dependencies
    solved.append(aPkg)
UnboundLocalError: local variable 'aPkg' referenced before assignment

Debug from /var/log/up2date follows.
Comment 6 Michal Nowak 2007-08-28 07:36:50 EDT
Created attachment 175981 [details]
up2date's log
Comment 7 Pradeep Kilambi 2007-08-29 15:04:42 EDT
yea there is a typo in there thats causing apkg. I fixed that.

Also One comment, you should not enter this code block at all unless there are
lots of obsoletes in the channel(which there should be unless you are going
outside of releases). In this case the reason you are hitting this is because
you are pointing proliant04 which is a rhel-4u6 to a Red Hat Enterprise Linux
(v. 5 for 32-bit x86) the activation key you are using is using rhel-5?? That
wont work ..! It might work in some cases, but its goona try solves deps for the
kernel and glibc packages like in this case it wont work (not supported for
now).That is the reason its trying to solve the deps as much as it can and
silently fails(after fixing the typo).. You should be pointing you box to an
activation-key which is a 4.5/4.6 subscribed and packages belonging to that set.

When I chnnge the base channel to Red Hat Default instead of RHEL-5 this is what
it does:

[root@proliant04 ~]# rhnreg_ks
--serverUrl=http://rlx-0-22.rhndev.redhat.com/XMLRPC
--activationkey=b9cf87711623aaf5db7d8be91c12af91 --force

thats because those are already installed.

[root@proliant04 ~]# rpm -q screen
screen-4.0.2-5


the same key with subscried to rhel-5,tries to do this:

[root@proliant04 ~]# rhnreg_ks
--serverUrl=http://rlx-0-22.rhndev.redhat.com/XMLRPC
--activationkey=b9cf87711623aaf5db7d8be91c12af91 --force

Name                                    Version        Rel     
----------------------------------------------------------
screen                                  4.0.3          1.el5             i386  
zsh                                     4.2.6          1                 i386  

in the process tries to do 
warning: package glibc = 2.5-12 was already added, replacing with glibc <= 2.5-12

which is not what you want. Unfortunately thats the limitation of activating
with akeys subscribed to a different channel.
Comment 11 errata-xmlrpc 2007-11-15 11:34:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0815.html

Note You need to log in before you can comment on or make changes to this bug.