Bug 243454 - firefox action "close tab" caused Xorg signal 11 Server abort
firefox action "close tab" caused Xorg signal 11 Server abort
Status: CLOSED DUPLICATE of bug 220629
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Patch
Depends On:
  Show dependency treegraph
Reported: 2007-06-08 15:36 EDT by James Crawford
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-25 18:22:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Most current Xorg log following crash (48.53 KB, text/plain)
2007-06-08 15:36 EDT, James Crawford
no flags Details
Copy of Xorg-log from after firefox -> x-server abort. (48.53 KB, text/plain)
2007-06-15 15:52 EDT, James Crawford
no flags Details
first upstream patch (809 bytes, patch)
2007-07-25 18:00 EDT, Matěj Cepl
no flags Details | Diff
second upstream patch (3.41 KB, patch)
2007-07-25 18:01 EDT, Matěj Cepl
no flags Details | Diff

External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 7205 None None None Never
Novell 211314 None None None Never

  None (edit)
Description James Crawford 2007-06-08 15:36:37 EDT
Opening severial tabs in firefox (x86-64) and closing them 1 at a time will cause 
the Xorg server to get a signak 11 and abort.

Not every close tab trigers this, but I have severial Xorg logs where it has
happened and can recreate it all to often, 6 crahses today.

If additional info needed I will try to provide it, I have tried to run ff from
the CmdLine redirecting sdtout & errout to a file but the file is empty after crash.
Comment 1 James Crawford 2007-06-08 15:36:37 EDT
Created attachment 156606 [details]
Most current Xorg log following crash
Comment 2 Warren Togami 2007-06-08 15:38:40 EDT
xgl-maint will probably ask you to provide more details.
Comment 3 James Crawford 2007-06-15 15:52:23 EDT
Created attachment 157153 [details]
Copy of Xorg-log from after firefox -> x-server abort.
Comment 4 James Crawford 2007-07-21 12:16:38 EDT
Anyone looking at this at all???
Opened a month ago and only comment is from FF maintainer.
I have applided all updates via yum update through today 2007-07-21 and on the
3rd "close tab" X crashed again. 
Back to FC6, and FF 1.5.*
Comment 5 Matěj Cepl 2007-07-23 06:53:49 EDT
Sorry for delay, but currently we have around 500 open bugs just for
gecko-related apps, so we are dancing as fast as we can, but it is certainly as
you (or we) would like to.
Comment 6 Christopher Aillon 2007-07-23 19:52:21 EDT
This really is an X bug anyway.  I just don't know what to re-assign it to.
Comment 7 Matěj Cepl 2007-07-25 09:23:00 EDT
Of course, you are right -- we usually go for different drivers, so this is our
beloved xorg-x11-driver-nv. Oh well :-(
Comment 8 James Crawford 2007-07-25 12:30:13 EDT
Should I test with the NVIDA Binary driver to confirm its an NV problem? 
Is there anything I can do to pin the problem portion of the code down (debug
options traces etc)?

I have the time, just need direction on what to do.

Comment 9 Matěj Cepl 2007-07-25 17:41:38 EDT
Sure, you can try it, if it works it could be interesting datapoint, but don't
even bother to send us the logs from binary-only nVidia driver -- they are
useless to us.
Comment 10 Matěj Cepl 2007-07-25 17:49:01 EDT
Seems to be reported also in the Novell bugzilla as
https://bugzilla.novell.com/show_bug.cgi?id=211314 and somebody mentioned this
for Fedora (don't if he has already filed the bug here in the Bugzilla).
Comment 11 Matěj Cepl 2007-07-25 17:56:41 EDT
And there is the upstream bug for this as well

Novell bug has been actually patched and there five patches attached to the bug
(I will reattach them to our bugzilla as well). The comments are very detailed
and thoroughfull (all 132 of them).
Comment 12 Matěj Cepl 2007-07-25 18:00:42 EDT
Created attachment 159984 [details]
first upstream patch

Actually, there are only two patches in the upstream bug, so I will rather
apply these.
Comment 13 Matěj Cepl 2007-07-25 18:01:37 EDT
Created attachment 159985 [details]
second upstream patch
Comment 14 Matěj Cepl 2007-07-25 18:22:56 EDT

*** This bug has been marked as a duplicate of 220629 ***

Note You need to log in before you can comment on or make changes to this bug.