Bug 243476 - thinkpad z61t (9442A69) cannot resume from suspend
thinkpad z61t (9442A69) cannot resume from suspend
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 17:47 EDT by Raphael SALSON
Modified: 2015-03-04 20:18 EST (History)
4 users (show)

See Also:
Fixed In Version: kernel-2.6.22.1-29.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-16 16:11:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael SALSON 2007-06-08 17:47:11 EDT
Description of problem:
Suspend to RAM:
- Laptop suspends fine. 
- When resuming, it starts to wake up but the suspend led remains steady (should
blink) and screen remains black and it stops there. 
- Not reactive to keys

Suspend to DISK:
- Laptop suspends fine
- When resuming, there is high disk activity (getting back the disk image?),
screens blinks then hangs.

Suspend/Resume to disk or RAM were working perfectly under fc6

Version-Release number of selected component (if applicable):
Fedora 7 (upgraded from fc6). All components upgraded via yum.
SMOLT UUID: 897275e9-247a-4c6f-8891-87a357a8595c

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Tried the following:
- Fallback to latest fc6 kernel
- Fallback video driver from intel to i810
- Tried to suspend from console mode
--> Problem still here.
Comment 1 Raphael SALSON 2007-06-14 17:29:51 EDT
upgrade to kernel 2.6.21-1.3228.fc7:
- same symptoms for hibernate
- same symptoms for suspend to ram

tried kernel from rawhide (2.6.21-1.3218.fc8), seems to improve things: resume
seems to work but screen remains black.

Graphic card is:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA])
        Subsystem: Lenovo Thinkpad R60e model 0657
        Flags: bus master, fast devsel, latency 0, IRQ 20
        Memory at ee100000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at 1800 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at ee200000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0
Enable-
        Capabilities: [d0] Power Management version 2

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
Express Integrated Graphics Controller (rev 03)
        Subsystem: Lenovo Thinkpad R60e model 0657
        Flags: fast devsel
        Memory at ee180000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [d0] Power Management version 2
Comment 2 Raphael SALSON 2007-06-16 12:08:20 EDT
[root@raphael ~]# lsmod 
Module                  Size  Used by
arc4                    6209  2 
ecb                     7489  2 
blkcipher              10181  1 ecb
ieee80211_crypt_wep     9281  1 
i915                   25793  3 
drm                    78037  4 i915
autofs4                24645  2 
hidp                   26433  2 
rfcomm                 43481  0 
l2cap                  30145  10 hidp,rfcomm
bluetooth              57253  5 hidp,rfcomm,l2cap
sunrpc                159133  1 
cpufreq_ondemand       11981  1 
acpi_cpufreq           14281  1 
dm_multipath           21705  0 
video                  21065  0 
sbs                    19173  0 
ibm_acpi               34905  0 
i2c_ec                  9281  1 sbs
button                 12113  0 
bay                    10177  0 
dock                   13669  1 bay
battery                14149  0 
ac                      9413  0 
ipv6                  276673  26 
parport_pc             29797  0 
lp                     15977  0 
parport                38025  2 parport_pc,lp
loop                   19785  0 
snd_hda_intel          24409  4 
snd_hda_codec         202689  1 snd_hda_intel
snd_seq_dummy           7877  0 
snd_seq_oss            33345  0 
ipw3945               188704  1 
ieee80211              35081  1 ipw3945
sr_mod                 20197  0 
ieee80211_crypt        10049  2 ieee80211_crypt_wep,ieee80211
cdrom                  37217  1 sr_mod
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                50353  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         11853  3 snd_seq_dummy,snd_seq_oss,snd_seq
ata_generic            12229  0 
snd_pcm_oss            43489  0 
snd_mixer_oss          19393  2 snd_pcm_oss
iwl3945               157221  0 
mac80211              145609  1 iwl3945
snd_pcm                74565  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
tifm_7xx1              12993  0 
fw_ohci                19649  0 
tifm_core              12993  1 tifm_7xx1
tg3                   104517  0 
snd_timer              24773  3 snd_seq,snd_pcm
fw_core                42625  1 fw_ohci
nsc_ircc               21841  0 
serio_raw              10821  0 
snd                    53189  13
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
cfg80211               12105  1 mac80211
sdhci                  21069  0 
irda                  118009  1 nsc_ircc
soundcore              11553  2 snd
mmc_core               30661  1 sdhci
snd_page_alloc         13769  2 snd_hda_intel,snd_pcm
pcspkr                  7105  0 
ata_piix               18885  0 
crc_ccitt               6337  1 irda
i2c_i801               12241  0 
i2c_core               24641  2 i2c_ec,i2c_i801
iTCO_wdt               14693  0 
joydev                 13441  0 
iTCO_vendor_support     7877  1 iTCO_wdt
sg                     37213  0 
dm_snapshot            20709  0 
dm_zero                 6209  0 
dm_mirror              24277  0 
dm_mod                 57229  9 dm_multipath,dm_snapshot,dm_zero,dm_mirror
ahci                   24261  2 
libata                115417  3 ata_generic,ata_piix,ahci
sd_mod                 23873  3 
scsi_mod              137549  4 sr_mod,sg,libata,sd_mod
ext3                  125385  2 
jbd                    59881  1 ext3
mbcache                12357  1 ext3
ehci_hcd               35405  0 
ohci_hcd               23749  0 
uhci_hcd               26833  0 

----
modules fw_ohci and fw_core are not culprits as indicated in another
suspend/resume bug. Tried to remove them but behaviour is exactly the same!
Comment 3 Raphael SALSON 2007-06-23 06:43:04 EDT
kernel from rawhide solves the resume-from-suspend and resume-from-hibernate hangs: 
2.6.21-1.3230.fc8

screen remains black but pm-utils quirk=s3_bios solves the issue:
posted details to hal mailing list.
Comment 4 Derek Atkins 2007-07-10 17:20:44 EDT
For the record, I noticed this with my T60 as well.  Suspend was working fine
with F7t4 but with the update to the F7 2.6.21 kernels I've been unable to
resume from suspend to ram.  For me when I attempt to resume it displays "inu"
in yellow and just sits there until I powercycle the system.   I haven't tried
the rawhide kernel (nor have I tried the updates-testing kernel) to see if it
fixes it.
Comment 5 Casey Harkins 2007-07-19 15:07:27 EDT
I have been experiencing the same problem with an X60 tablet. I just tried the
kernel-2.6.22.1-20.fc7 available here http://people.redhat.com/~davej/ and
everything (so far) seems to be working!
Comment 6 Derek Atkins 2007-07-23 19:23:43 EDT
I just installed kernel-2.6.22.1-29.fc7 as pointed to by comment #5 and I can
verify that suspend-to-ram works for me again.  I was able to suspend and it
successfully resumed.  Nice work, guys.
Comment 7 Christopher Brown 2007-09-16 16:11:07 EDT
Closing as the issue is resolved.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.