Bug 243481 - JPilot stops transfer immediately after start. (Reset?)
Summary: JPilot stops transfer immediately after start. (Reset?)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: jpilot (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-08 22:21 UTC by Adalbert Prokop
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 21:47:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adalbert Prokop 2007-06-08 22:21:25 UTC
I can't synchronize my Handspring Visor Deluxe with JPilot. I used this
combination with every previous Fedora version.

The connection seems to be resetted at the time I push the "sychronize" button
in JPilot. pilot-xfer works fine, showing the contents of my Visor (-l) and
fetching some random files (-f). Both programs, pilot-xfer and jpilot, use
/dev/pilot which is a symlink to ttyUSB1. I use a USB docking station.
I've tried to access /dev/ttyUSB1 directly from JPilot with the same result.

The message pane withing JPilot shows
****************************************
 Syncing on device /dev/ttyUSB1
 Press the HotSync button now
****************************************
But Visor shows a message about a resetted connection.


Version-Release number of selected component (if applicable):
jpilot-0.99.9-3.fc7
pilot-link-0.12.1-6.fc7

Steps to Reproduce:
1. Push sync button on the docking station
2. Push sync button in JPilot
3. Immediately read a message about a resetted connection on Visor's display

Comment 1 Adalbert Prokop 2007-06-16 21:47:36 UTC
Okay, it seems it was my fault and not a bug.
Today I browsed through JPilot's settings once again and looked closer to the
serial rate option. It was set to 9600. Since it also says "Does not affect USB"
I just ignored it.

But JPilot magically synchronized again after I've set this value to H460800.
The essence: JPilot is not buggy, but the description is highly misleading.


Note You need to log in before you can comment on or make changes to this bug.