Bug 243505 - kdm fails to start X server after logout
kdm fails to start X server after logout
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 04:48 EDT by Tomasz Kepczynski
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 07:35:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested xorg.conf (588 bytes, text/plain)
2007-07-05 09:21 EDT, Niko Mirthes
no flags Details
Requested Xorg.0.log (45.91 KB, text/plain)
2007-07-05 09:22 EDT, Niko Mirthes
no flags Details
Requested Xorg.0.log without xorg.conf (49.43 KB, text/plain)
2007-07-05 09:37 EDT, Niko Mirthes
no flags Details
requested xorg.conf (1.22 KB, application/octet-stream)
2007-07-06 05:13 EDT, Tomasz Kepczynski
no flags Details
requested log file (56.13 KB, text/plain)
2007-07-06 05:13 EDT, Tomasz Kepczynski
no flags Details
requested log file (no xorg.conf) (59.69 KB, text/plain)
2007-07-06 05:14 EDT, Tomasz Kepczynski
no flags Details

  None (edit)
Description Tomasz Kepczynski 2007-06-09 04:48:25 EDT
Description of problem:
I've setup my desktop to kdm display manager. After system
boots up login screen is displayed as expected. Then I log in
and log out. After logout server is not started and I am dropped
to command line login screen on vty1.
There is no such a problem with gdm.

Version-Release number of selected component (if applicable):
kdebase-3.5.6-12.fc7.x86_64
kdebase-3.5.6-12.fc7.i386

How reproducible:
always

Actual results:
No graphical login screen after the first session is finished.

Expected results:
Graphical login screen as configured.

Additional info:
The only trace I found from this fault is:
Fatal server error:
could not open default font 'fixed'
in /var/log/kdm.log
which may point to problems with font server of permissions
on its socket (consolekit?, selinux?). Fontserver is running
however.
Comment 1 Niko Mirthes 2007-06-13 11:08:20 EDT
I'm seeing the same. I have /usr/share/X11/fonts/misc populated and xfs 
running, so I doubt that's the issue. This seemed to start after one of the 
recent Xorg-related updates.
Comment 2 Niko Mirthes 2007-06-13 12:01:24 EDT
A bit of poking around reveals:

Jun 13 12:53:26 localhost setroubleshoot:      SELinux is 
preventing /sbin/pam_console_app
ly (pam_console_t) "append" to /var/log/kdm.log (xserver_log_t).      For 
complete SELinux
 messages. run sealert -l 1cd15cf9-2db2-474f-b591-3672779e05d9
Jun 13 12:53:28 localhost setroubleshoot: [program.ERROR] Can not handle AVC'S 
related to
dispatcher. exiting setroubleshoot 
context=system_u:system_r:setroubleshootd_t:s0, AVC sco
ntext=system_u:system_r:setroubleshootd_t:s0
Jun 13 12:53:29 localhost kdm: :0[9600]: IO Error in XOpenDisplay
Jun 13 12:53:29 localhost kdm[9197]: Display :0 cannot be opened
Jun 13 12:53:29 localhost kdm[9197]: Unable to fire up local display :0; 
disabling.
Jun 13 12:53:42 localhost audispd[1798]:  writev(6): Broken pipe

printed to /var/log/messages on logout.
Comment 3 Niko Mirthes 2007-06-13 12:10:07 EDT
After removing setroubleshoot-server and setroubleshoot I'm left with:

Jun 13 13:02:42 localhost kdm: :0[2980]: IO Error in XOpenDisplay
Jun 13 13:02:42 localhost kdm[2576]: Display :0 cannot be opened
Jun 13 13:02:42 localhost kdm[2576]: Unable to fire up local display :0; 
disabling.
Comment 4 Dean Mander 2007-06-18 17:35:42 EDT
I've had the same issue: kdm starts up fine but stops after logout.

I also have the selinux error, but it is unrelated to this issue. The issue (of
me) is a crash of xfs: somewhere during the logout, xfs crashes and it is
impossible to restart it.

In my case, this was because my /tmp was a symblink to a directory on a
partition which was mounted with options nodev,nosuid,noexec.

After removing the symblink and creating /tmp in standard way, no xfs problems
anymore.

Comment 5 Niko Mirthes 2007-06-21 00:13:33 EDT
While trying to log in using xdmcp and kdm (see bug #243560), I wound up with 
complaints about the fixed font missing. After installing:

xorg-x11-fonts-100dpi
xorg-x11-fonts-75dpi
xorg-x11-fonts-base

and restarting xfs, this problem appears to have disappeared for me.
Comment 6 Niko Mirthes 2007-07-02 05:48:14 EDT
I believe I have a simple method to reproduce this now. Simply stop and 
disable the xfs daemon. There may also be a need to remove any FontPath 
references in xorg.conf. I'd also removed all the xorg-x11-fonts-* fonts 
installed, but that seems to have no bearing on this.

For me, logging out after doing this results in X/Kdm failing to restart. 
Starting the xfs service again returns things to a working state.
Comment 7 Rex Dieter 2007-07-02 05:56:00 EDT
Reassigning kdebase -> xfs.  xfs shouldn't be dieing, period (imo).
Comment 8 Matěj Cepl 2007-07-02 06:53:52 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 9 Niko Mirthes 2007-07-05 09:21:35 EDT
Created attachment 158580 [details]
Requested xorg.conf
Comment 10 Niko Mirthes 2007-07-05 09:22:25 EDT
Created attachment 158581 [details]
Requested Xorg.0.log
Comment 11 Niko Mirthes 2007-07-05 09:37:48 EDT
Created attachment 158582 [details]
Requested Xorg.0.log without xorg.conf
Comment 12 Niko Mirthes 2007-07-05 09:40:01 EDT
While preparing these files I noticed the KDE session in use became nearly 
unresponsive, taking 10-30 seconds to respond to user activity. Oddly, mouse 
movement seemed to help.
Comment 13 Tomasz Kepczynski 2007-07-06 05:13:22 EDT
Created attachment 158646 [details]
requested xorg.conf
Comment 14 Tomasz Kepczynski 2007-07-06 05:13:55 EDT
Created attachment 158647 [details]
requested log file
Comment 15 Tomasz Kepczynski 2007-07-06 05:14:39 EDT
Created attachment 158648 [details]
requested log file (no xorg.conf)
Comment 16 Tomasz Kepczynski 2007-07-06 05:19:13 EDT
(In reply to comment #7)
> Reassigning kdebase -> xfs.  xfs shouldn't be dieing, period (imo).
For the recored - in my case xfs IS NOT DIEING.
I have noticed that after doing:
# telinit 3
# telinit 5
I am able to login (no xfs restart during the above).
Comment 17 Rex Dieter 2007-07-24 18:56:39 EDT
Re-assigning back to kdebase...

Anyone seeing this *not* on x86_64?
Comment 18 Rex Dieter 2007-11-08 11:48:39 EST
anyone still seeing this, please make sure you have base-x installed:
yum groupinstall base-x
and try to reproduce.
Comment 19 Tomasz Kepczynski 2007-11-09 06:23:17 EST
It seems to work now. I've found out that xorg-x11-fonts-base
makes a difference but I don't know why it wasn't installed in
the first place.
Comment 20 Rex Dieter 2007-11-09 07:35:55 EST
OK, thanks for confirming.

Note You need to log in before you can comment on or make changes to this bug.