Bug 243514 - mac80211 does not support set bit rate ioctl
Summary: mac80211 does not support set bit rate ioctl
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i686 Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-09 10:25 UTC by Casual J. Programmer
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version: 2.6.22.2-57.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 18:45:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Casual J. Programmer 2007-06-09 10:25:40 UTC
After setting up an Intel ipw3945 with f7 on ifup wlan0 the following message is
issued:

[root@workstation6l cjp]# ifup wlan0
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wlan0 ; Operation not supported.

Determining IP information for wlan0... done.

issuing iwpriv wlan0 shows:

[root@workstation6l cjp]# iwpriv wlan0
wlan0     Available private ioctls :
          param            (8BE0) : set   2 int   & get   0      
          get_param        (8BE1) : set   1 int   & get   1 int  

"Bit Rate" is not listed as an available option.

Kernel is: 2.6.21-1.3194.fc7 #1 SMP 

How reproducible: start network interface wlan0

Steps to Reproduce:
1. ifdown wlan0
2. ifup wlan0
  
Actual results: Error for wireless request "Set Bit Rate" (8B20) :
                SET failed on device wlan0 ; Operation not supported.

Expected results: No error

Comment 1 John W. Linville 2007-06-13 15:49:46 UTC
iwlwifi uses mac80211, mac80211 does not implement the set bit rate ioctl.  
One of the upstream wireless developers is actively working on this right now.

In the mean time, the message you see can be safely ignored.  BTW, iwpriv is 
not the right command for that anyway -- "iwconfig wlan0 rate".

Comment 2 Casual J. Programmer 2007-06-14 16:30:12 UTC
Good to know, somebody out there ought to know that iwpriv is not the correct
way. Because 

root@workstation6l cjp]# ifup wlan0
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wlan0 ; Operation not supported.

happens when ifup is issued, not while I issue iwpriv :-(

Comment 3 John W. Linville 2007-07-16 21:06:59 UTC
Does this problem persist w/ current rawhide kernels (e.g. 
kernel-2.6.23-0.29.rc0.git6.fc8 or later)?

Comment 4 John W. Linville 2007-08-21 18:45:35 UTC
This ioctl is supported now.


Note You need to log in before you can comment on or make changes to this bug.