Bug 243519 - Libata in F7 Kernel causes pata Device to behave wrong
Libata in F7 Kernel causes pata Device to behave wrong
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 07:18 EDT by Stefan Held
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 12:01:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages file booting F7 for the first time with sdc detected incorrectly (25.51 KB, application/octet-stream)
2007-06-15 03:35 EDT, Ivan Szanto
no flags Details
messages file booting FC6 with hdd detected correctly (15.76 KB, application/octet-stream)
2007-06-15 03:38 EDT, Ivan Szanto
no flags Details

  None (edit)
Description Stefan Held 2007-06-09 07:18:02 EDT
Description of problem:

Booting up with the F7 Kernel 2.6.21-1.3194.fc7 i get messages about device sbd1 

Jun  8 23:42:44 bigbox kernel: scsi 0:0:1:0: Direct-Access     ATA      SAMSUNG
SP2014N  VC10 PQ: 0 ANSI: 5
Jun  8 23:42:44 bigbox kernel: SCSI device sdb: 66055248 512-byte hdwr sectors
(33820 MB)
Jun  8 23:42:44 bigbox kernel: sdb: Write Protect is off
Jun  8 23:42:44 bigbox kernel: SCSI device sdb: write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
Jun  8 23:42:44 bigbox kernel: SCSI device sdb: 66055248 512-byte hdwr sectors
(33820 MB)
Jun  8 23:42:44 bigbox kernel: sdb: Write Protect is off
Jun  8 23:42:44 bigbox kernel: SCSI device sdb: write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
Jun  8 23:42:44 bigbox kernel:  sdb: sdb1
Jun  8 23:42:44 bigbox kernel:  sdb: p1 exceeds device capacity
Jun  8 23:42:44 bigbox kernel: sd 0:0:1:0: Attached scsi disk sdb

Jun  8 23:42:44 bigbox kernel: attempt to access beyond end of device
Jun  8 23:42:44 bigbox kernel: sdb: rw=0, want=390721794, limit=66055248
Jun  8 23:42:44 bigbox kernel: attempt to access beyond end of device
Jun  8 23:42:44 bigbox kernel: sdb: rw=0, want=390721794, limit=66055248
Jun  8 23:42:44 bigbox kernel: attempt to access beyond end of device
Jun  8 23:42:44 bigbox kernel: sdb: rw=0, want=390660361, limit=66055248

and so on.

Rebooting with the latest FC6 Kernel fixes this behavior.
Everything runs perfect after a really long fsck and some lost files.

Version-Release number of selected component (if applicable):

2.6.21-1.3194.fc7

How reproducible:

Boot with F7 Kernel and my Hardware :)


Steps to Reproduce:
1. Boot
2.
3.
  
Actual results:

Device sbd1 is not working.

Expected results:

Device sbd1 should work.

Additional info:

http://smolt.fedoraproject.org/show?UUID=78444b39-4bee-4257-8adb-b9bb342850fd
Comment 1 Alan Cox 2007-06-11 10:43:55 EDT
Jun  8 23:42:44 bigbox kernel:  sdb: sdb1
Jun  8 23:42:44 bigbox kernel:  sdb: p1 exceeds device capacity


Your disk is partitioned with larger partitions than the disk size reported. 
What occurs if you pass the boot option needed.

See http://fedoraproject.org/wiki/Bugs/F7Common
Comment 2 Ivan Szanto 2007-06-15 03:33:46 EDT
Thanks Alan, that did the trick for me. I think I had the same problem. 

What is strange about it that AFAIK this really was not a "host protected area"
problem, but it was my old BIOS that fails to detect the size of my new hard
disk correctly (it detects 33G instead of 300G). I attach some logs for
reference. It might be useful for others to know that the ignore_hpa flag also
fixes this problem.
Comment 3 Ivan Szanto 2007-06-15 03:35:46 EDT
Created attachment 157066 [details]
messages file booting F7 for the first time with sdc detected incorrectly
Comment 4 Ivan Szanto 2007-06-15 03:38:32 EDT
Created attachment 157067 [details]
messages file booting FC6 with hdd detected correctly

the drive sdc under F7 is hdd under FC6
Comment 5 Alan Cox 2007-06-15 12:01:00 EDT
I bet you have the 32GB jumper set on the drive. That causes the drive to add an
HPA itself.

Good to know it works anyway, I'm hoping by FC8 people are confident enough to
make this the default.
Comment 6 Stefan Held 2007-06-16 04:16:51 EDT
> Your disk is partitioned with larger partitions than the disk size reported. 
> What occurs if you pass the boot option needed.

Indeed, the Fix libata ignore_hpa=1 works for me.


Note You need to log in before you can comment on or make changes to this bug.