Bug 243524 - Installer misses some IPv6 configuration items
Summary: Installer misses some IPv6 configuration items
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Joel Andres Granados
QA Contact: Milan Zázrivec
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-09 12:30 UTC by Sander Steffann
Modified: 2008-05-21 15:30 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 15:30:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/network (73 bytes, text/plain)
2008-02-06 14:30 UTC, Milan Zázrivec
no flags Details
/etc/sysconfig/network-scripts/ifcfg-eth0 (203 bytes, text/plain)
2008-02-06 14:31 UTC, Milan Zázrivec
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0397 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2008-05-19 23:11:23 UTC

Description Sander Steffann 2007-06-09 12:30:07 UTC
Description of problem:
The installer asks for IPv6 addresses, but does not ask for an IPv6 default
gateway. It also forgets IPV6INIT=yes in the
/etc/sysconfig/network-scripts/ifcfg-* files, although it does put in the
IPV6ADDR= line.

Version-Release number of selected component (if applicable):
RHEL5

How reproducible:
Install a system and provide IPv6 addresses

Steps to Reproduce:
1.Start installation
2.Continue to networking settings
3.Enter IPv6 addresses
4.Notice missing default gateway information
5.Finish installation
6.Check /etc/sysconfig/network: no IPV6_DEFAULTGW
7.Check /etc/sysconfig/network-scripts/ifcfg-eth0, no IPV6INIT
  
Actual results:


Expected results:


Additional info:

Comment 2 David Cantrell 2007-09-13 21:53:20 UTC
We can add IPV6INIT easily, but prompting for the default gateway for manual
installs isn't doable for 5.2.  We have to implement that in Fedora first.

Adding devel-ack, but for IPV6INIT only.

Comment 3 RHEL Product and Program Management 2007-10-16 03:58:04 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Joel Andres Granados 2007-12-07 12:07:16 UTC
Backported from rawhide code with no test.

Comment 7 Milan Zázrivec 2008-02-06 14:30:12 UTC
RHEL5.2-{Client,Server}-20080206.nightly:

/etc/sysconfig/network-scripts/ifcfg-eth* sure contains IPV6INIT=yes line.

Nonetheless, the IPv6 address I had set for eth0 during installation has vanished.
In anaconda, I have selected manual IPv6 configuration  for eth0 interface and
put a custom value in. After the reboot, IPv6 was active on eth0, but eth0
was using it's site-local address (instead of the one I had specified in
anaconda -- most likely caused by IPV6ADDR=none line in the ifcfg-eth0 file).

I'm not sure whether this is related or not -- anyway, I'll be happy to open
a new bugzilla for this if needed.

Comment 8 Milan Zázrivec 2008-02-06 14:30:42 UTC
Created attachment 294104 [details]
/etc/sysconfig/network

Comment 9 Milan Zázrivec 2008-02-06 14:31:15 UTC
Created attachment 294105 [details]
/etc/sysconfig/network-scripts/ifcfg-eth0

Comment 12 Milan Zázrivec 2008-02-08 15:55:54 UTC
I'm verifying presence of IPV6INIT=yes line in ifcfg-eth* file
in RHEL5.2-{Client,Server}-20080206.nightly.

Comment 13 Milan Zázrivec 2008-02-08 15:58:06 UTC
I'm not sure whether the problem with IPV6ADDR=none I mentioned in comment #7
is a bug or a feature, but I filed a new bz for it: bug #432035.

Comment 15 errata-xmlrpc 2008-05-21 15:30:19 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html



Note You need to log in before you can comment on or make changes to this bug.