Bug 243542 - snd_emu10k1 fails (no sound) on Fedora 7
snd_emu10k1 fails (no sound) on Fedora 7
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: sndconfig (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
http://www.dwheeler.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 12:09 EDT by David A. Wheeler
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 00:07:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log (36.00 KB, text/plain)
2007-06-09 12:09 EDT, David A. Wheeler
no flags Details
scsconfig.log, after regenerating configuration file and rebooting (41.12 KB, text/plain)
2007-06-11 20:22 EDT, David A. Wheeler
no flags Details
scsconfig.log from Dell Optiplex GX260 (40.87 KB, text/plain)
2007-12-12 15:36 EST, Michael Wiktowy
no flags Details

  None (edit)
Description David A. Wheeler 2007-06-09 12:09:00 EDT
Description of problem:
No sound after upgrading to Fedora 7, on a system with Creative Labs Sound
Blaster Live! EMU10k1.  It worked on Fedora Core 6.  Admin/Soundcard detection
correctly detects card, but tests produce no sound.

Version-Release number of selected component (if applicable):
I believe the relevant file is:
/lib/modules/2.6.21-1.3194.fc7/kernel/sound/pci/emu10k1/snd-emu10k1.ko

So "rpm -qif /lib/modules/2.6.21-1.3194.fc7/kernel/sound/pci/emu10k1/snd-emu10k1.ko"
produces
Name        : kernel                       Relocations: (not relocatable)
Version     : 2.6.21                            Vendor: Koji
Release     : 1.3194.fc7    


How reproducible:



Steps to Reproduce:
1. Install Fedora Core 6, works fine.
2. Boot Fedora Core "Recover" disk, upgrade to Fedora 7.
3. System->Admin->Soundcard detection.  Push "Play" button in sound test.
4. Changing SELinux to "Permissive" doesn't help.
  
Actual results:
No sound.

Expected results:
Hear test sound.

Additional info:
from scsrun.log:
------- System Config Soundcard Log --------
Sat Jun  9 11:51:37 EDT 2007

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16 b
it Little Endian, Rate 44100 Hz, Stereo
Aborted by signal Terminated...


I've attached scsconfig.log.
Comment 1 David A. Wheeler 2007-06-09 12:09:00 EDT
Created attachment 156652 [details]
scsconfig.log
Comment 2 David A. Wheeler 2007-06-10 14:20:18 EDT
Sound does NOT work when booting directly from the Fedora 7 Live CD.  So it's a
problem with Fedora 7, whether you upgrade or boot it directly, with Creative
Labs' "Soundblaster Live! EMU10k1".  Since it worked under Fedora Core 6, and
nothing changed between, something made it not work.

Comment 3 Martin Stransky 2007-06-11 07:12:04 EDT
please update your system, run system-config-soundcard, switch to "System" page,
select "Rewrite configuration file" and reboot your box.
Comment 4 David A. Wheeler 2007-06-11 20:20:36 EDT
Thanks for the suggestion.  I did what you suggested, but no joy.  I will
regenerate and repost scsconfig.log in case that gives any hints.
Comment 5 David A. Wheeler 2007-06-11 20:22:00 EDT
Created attachment 156770 [details]
scsconfig.log, after regenerating configuration file and rebooting
Comment 6 lynn wheeler 2007-06-15 09:31:27 EDT
I have same (DELL Dimension 8300) EMU10K1 problem ... works with FC6, upgrade to
F7 and no sound.
Comment 7 David A. Wheeler 2007-06-15 11:33:08 EDT
It appears that the EMU10K doesn't work on Fedora 7 for others as well. "tyront"
reports on "Fedoraforum.org", here:
http://forums.fedoraforum.org/archive/index.php/t-156521.html
Subject "Sound blaster 5.1 live not working in fedora 7".  tyront reports that
EMU10k worked on Fedora Core 5 and 6, but while all the STATUS reports say it's
working, no sound comes out with Fedora 7.  That's the same experience I have.

Comment 8 David A. Wheeler 2007-06-16 18:11:41 EDT
FYI, kernel upgrade doesn't help, still no sound with emu10k1.

I upgraded everything Friday, including the kernel.  It's now running
(/proc/version): "Linux version 2.6.21-1.3228.fc7
(kojibuilder@xenbuilder4.fedora.phx.redhat.com) 
(gcc version 4.1.2 20070502 (Red Hat 4.1.2-12)) #1 SMP Tue Jun 12 14:39:26 EDT 2
007". I then did Admin/Soundcard detection, no sound.  I even did System/Rewrite
configuration files, and then tried again.  No sound.

Any ideas on what to test/look for?
Comment 9 Martin Stransky 2007-06-26 11:16:05 EDT
Please check the new drivers - http://people.redhat.com/stransky/alsa/
Comment 10 David A. Wheeler 2007-06-30 23:13:24 EDT
Thanks for the pointer! But sadly, the new drivers and other tips didn't help.

I re-updated the kernel, alsa, etc. I then examined the tips here:
http://people.redhat.com/stransky/alsa/

I tried using aplay and alsaunmute; no errors, but no sound.
I then downloaded and installed the pointed-to drivers; I installed them using:
rpm -i alsa-driver-1.0.14-61.fc7.i386.rpm
alsa-driver-devel-1.0.14-61.fc7.i386.rpm
alsa-kmdl-2.6.21-1.3228.fc7-1.0.14-61.fc7.i586.rpm 

I think that's correct; I have an x86, no PAE kernel, and /proc/version says:
Linux version 2.6.21-1.3228.fc7 (kojibuilder@xenbuilder4.fedora.phx.redhat.com)
(gcc version 4.1.2 20070502 (Red Hat 4.1.2-12)) #1 SMP Tue Jun 12 14:39:26 EDT 2007

Rebooted - no sound.  I then went through soundcard detection; no errors, but
when trying to play the sound, there's no still no sound.

I'm out of ideas on this one.  Any other ideas/requests for information?

Comment 11 Martin Stransky 2007-08-15 12:42:54 EDT
I idea what's wrong. Please report it to upstream (ALSA project) and ask / file
bug there. They're authors of linux sound system should be able to help you....

anyway, new drivers are in updates for F7...
Comment 12 Michael Wiktowy 2007-12-12 15:22:20 EST
A similar problem here on a Dell Optiplex GX260 running F8.
Test sound works in System->Administration->Sound Card Detection but no devices
are listed in System->Preferences->Hardware->Sound
I have stripped out all the PulseAudio packages to see if that was being
problematic but it got no better (or worse). Just silent except for the sound
card test that works perfectly.
lspci reports:
02:07.0 Multimedia audio controller: Creative Labs [SB Live! Value] EMU10k1X
02:07.1 Input device controller: Creative Labs [SB Live! Value] Input device
controller

Comment 13 Michael Wiktowy 2007-12-12 15:26:24 EST
Regarding Comment #3:
The option on that tab are "Restore configuration files" and "Reset
configuration files". It is not entirely clear which one "Rewrites configuration
files"
Comment 14 Michael Wiktowy 2007-12-12 15:36:57 EST
Created attachment 286131 [details]
scsconfig.log from Dell Optiplex GX260

Attaching scsconfig.log to bug. The system seems to recognize that there is a
sound card present. Just not usable by any applications.
Comment 15 Michael Wiktowy 2007-12-31 11:44:48 EST
I can happily report that as of kernel 2.6.23.9-85.fc8, the soundcard on my Dell
Optiplex GX260 is properly detected and works as expected.

Thanks.
Comment 16 Brian Powell 2008-04-25 00:07:05 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note that maintenance for Fedora 7 will end 30 days after the GA of Fedora 9.

Note You need to log in before you can comment on or make changes to this bug.