Bug 243559 - FC7 can not stop hard disk properly
Summary: FC7 can not stop hard disk properly
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-09 18:37 UTC by Alexey Titov
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 19:12:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexey Titov 2007-06-09 18:37:28 UTC
Description of problem:
I have Asus A2800S laptop. FC6 detected my hard disk as IDE (hda) and computer
halted normally. FC7 detects hard disk as SATA (sda). When system is halting
(just before power off) I hear a suspicious "click" from hard disk. I have to
downgrade kernel to 2.6.18-1.2869.fc6.

Version-Release number of selected component (if applicable):
2.6.21-1.3194.fc7

How reproducible:
always

Steps to Reproduce:
1. halt system
  
Actual results:
system is halted, but hard disk is not halted properly

Expected results:
disk must be halted quietly

Comment 1 Andre Robatino 2007-06-09 20:40:18 UTC
  I was wondering about this too.  The HD makes a much louder sound just before
turning off than it did in FC6, almost a thump.  I have no idea if it's anything
to be concerned about.

Comment 2 Andre Robatino 2007-06-10 02:39:44 UTC
  This appears to be a duplicate of bug #243021.

Comment 3 Christopher Brown 2007-09-16 20:17:13 UTC
Hello Alexey,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

(In reply to comment #2)
>   This appears to be a duplicate of bug #243021.

This bug has been closed by the reporter - I'm aware of the other issues you are
having Andre but could you tell me if you are still having problems with this as
well?

There hasn't been much activity on this bug for a while. Could you (the
reporter) tell me if you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 4 Andre Robatino 2007-09-16 20:57:08 UTC
  This has been fixed for me for a while now.

Comment 5 Alexey Titov 2007-09-17 19:12:26 UTC
No, I do not have this bug now. I do not use Fedora any more... Now I use
Ubuntu. There was the same problem, but I find a workaround:

echo 1 > /sys/class/scsi_disk/0\:0\:0\:0/stop_on_shutdown


Note You need to log in before you can comment on or make changes to this bug.