Bug 243564 - F7 fails to update fron FC6
F7 fails to update fron FC6
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Martin Sivák
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 16:26 EDT by Nigel Horne
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 11:56:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2007-06-09 16:26:14 EDT
Description of problem:
Boot off DVD: after hitting next a few times then correcting the keyboard layout
I see:

An error occurred mounting device hda1 as /mnt/winxp.
You may continue [the] installation, but there may be problems. Reboot/Countine.

Hit continue, then:

An error occurred mounting device hdb1 as /mnt/win2.
You may continue [the] installation, but there may be problems. Reboot/Countine.

Hit continue, then:

Error mounting device hdb3 as /usr: No such file or directory
Devices in/etc/fstab should be specified by [a] label, not by [a] device name
Press OK to reboot your system.


Version-Release number of selected component (if applicable):
F7


How reproducible:
100%

Steps to Reproduce:
1. Insert DVD, boot and try to upgrade the existing F6 system
2.
3.
  
Actual results:
See above


Expected results:
Should install Linux.


Additional info:
Comment 1 Chris Lumens 2007-06-15 13:43:35 EDT
What does the /etc/fstab file on your FC6 installation look like?
Comment 2 Nigel Horne 2007-06-15 16:48:57 EDT
LABEL=/                 /                       ext3    noatime        1 1
LABEL=/boot             /boot                   ext3    noatime        1 2
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/hda1               /mnt/winxp              vfat   
uid=500,rw,nosuid,dev,exec,noatime,umask=000,shortname=winnt    0 0
/dev/hdb1               /mnt/win2               vfat   
uid=500,rw,nosuid,dev,exec,noatime,umask=000,shortname=winnt    0 0
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0
/dev/hdb2               swap                    swap    defaults        0 0
/dev/sda5               /mnt/openbsd    ufs     ufstype=44bsd,ro        0 0
LABEL=/dev/hda6             /usr                    ext3    noatime         1 2
Comment 3 Ralf Kleineisel 2007-07-24 06:05:03 EDT
Try to substitue all "/dev/hdXX" entries in /etc/fstab with "/dev/sdXX" and then
boot the install disk.
Comment 4 Nigel Horne 2007-07-24 11:12:24 EDT
Wouldn't that clash with my scsi disc?

LABEL=/                 /                       ext3    noatime        1 1
LABEL=/boot             /boot                   ext3    noatime        1 2
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/hda1               /mnt/winxp              vfat   
uid=500,rw,nosuid,dev,exec,noatime,umask=000,shortname=winnt    0 0
/dev/hdb1               /mnt/win2               vfat   
uid=500,rw,nosuid,dev,exec,noatime,umask=000,shortname=winnt    0 0
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0
/dev/hdb2               swap                    swap    defaults        0 0
/dev/sda5               /mnt/openbsd    ufs     ufstype=44bsd,ro        0 0
# /dev/hda6             /mnt/freebsd            ufs     ufstype=5xbsd,ro        0 0
LABEL=/home             /home                   ext3    noatime         1 2
LABEL=/usr              /usr                    ext3    noatime         1 2
Comment 6 Martin Sivák 2007-09-20 11:56:50 EDT
This happened because of kernel change (my guess is the libata became default),
so I'm really not able to do anything about it except to advice you to change
the /etc/fstab as mentioned before. And yes, it will share the /dev/sdXX
namespace with your existing SCSI device, so make sure you use correct device names.

Fedora 7 and further versions now use only the sdXX devices.
Comment 7 Nigel Horne 2007-09-20 12:02:39 EDT
So, if I change /dev/hda1 to /dev/sda1, what do I do to /dev/sda5? Does it now
become /dev/sdc5?

What a mess :-(
Comment 8 Martin Sivák 2007-09-21 02:47:44 EDT
It depends on the specific setup you have there, but it is possible. The best
solution is to use labels, then you won't have to worry about specific device names.

This information is present in release notes too:
http://docs.fedoraproject.org/release-notes/f7/en_US/sn-Installer.html#Upgrade-Related-Issues
Comment 9 Nigel Horne 2007-10-02 10:08:19 EDT
I commented out the SCSI disc (since that's of secondary use) to see if that
would help. But is doesn't, now the program says:

Error Enabling Swap Device hdb2: no such file or directory
The /etc/fstab on your upgrade system does not reference a valid swap partition

Press OK to reboot your system.

Why was I not given an option by the program to tell it where to find the swap
partition, and why it didn't scan the partitions on the system to find it
automatically.

Note You need to log in before you can comment on or make changes to this bug.