Bug 243578 - gnome-screensaver doesn't start automatically.
Summary: gnome-screensaver doesn't start automatically.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact:
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-10 02:36 UTC by sangu
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 04:54:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
~/.xsession-errors doesn't has gnome-screensaver's error log. (6.68 KB, text/plain)
2007-06-12 12:57 UTC, sangu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 445942 None None None Never

Description sangu 2007-06-10 02:36:17 UTC
Description of problem:
gnome-screensaver doesn't start automatically

/apps/gnome_settings_daemon/screensaver/start_screenaver value is true.

Version-Release number of selected component (if applicable):
2.19.3-6.fc8

How reproducible:
always

Steps to Reproduce:
1. Booting login
2. Launch gnome-terminal
3. ps ax | grep gnome-screensaver
  
Actual results:


Expected results:


Additional info:
gnome-session-2.19.3-1.fc8
dbus-1.0.2-4.fc7
gnome-screensaver-2.19.1.1-1.fc8

Comment 1 Ray Strode [halfline] 2007-06-10 14:48:30 UTC
logged in as root?

Comment 2 sangu 2007-06-10 14:55:44 UTC
No, normal user.

Comment 3 Jeremy Katz 2007-06-10 22:33:08 UTC
I noticed this on my rawhide update on Friday also

Comment 4 Ray Strode [halfline] 2007-06-11 01:24:39 UTC
If you type gnome-screensaver at the console does it start?


Comment 5 sangu 2007-06-11 03:01:03 UTC
Booting
Launch gnome-terminal
$ ps ax | grep gnome-screensaver
 3170 pts/0    S+     0:00 grep gnome-screensaver
$ gnome-screensaver

***MEMORY-WARNING***: gnome-screensaver[3177]: GSlice: g_thread_init() must be
called before all other GLib functions; memory corruption due to late invocation
of g_thread_init() has been detected; this program is likely to crash, leak or
unexpectedly abort soon...

$ ps ax | grep gnome-screensaver
 3178 ?        Ss     0:00 gnome-screensaver
 3182 pts/0    S+     0:00 grep gnome-screensaver

gnome-screensaver starts well at the console.

Comment 6 Bastien Nocera 2007-06-11 09:10:39 UTC
Could you please set the following GConf key to true:
/apps/gnome_settings_daemon/screensaver/show_startup_errors

and let us know of any errors on session startup?

Comment 7 sangu 2007-06-11 09:23:57 UTC
(In reply to comment #6)
> Could you please set the following GConf key to true:
> /apps/gnome_settings_daemon/screensaver/show_startup_errors

$ gconftool-2 --get /apps/gnome_settings_daemon/screensaver/show_startup_errors
[...]
true

/apps/gnome_settings_daemon/screensaver/show_startup_errors' default value is true.

> let us know of any errors on session startup? 
No.


> and let us know of any errors on session startup?



Comment 8 Bastien Nocera 2007-06-11 09:33:28 UTC
So you get a warning in the startup logs, and gnome-screensaver isn't running
after a little while (ie. no output in "ps aux | grep gnome-screensaver")?

If so, that would mean that gnome-screensaver is crashing, and it's a problem
with gnome-screensaver.

Comment 9 sangu 2007-06-12 12:57:24 UTC
Created attachment 156791 [details]
~/.xsession-errors  doesn't has gnome-screensaver's error log.

(In reply to comment #8)
> So you get a warning in the startup logs, and gnome-screensaver isn't running

> after a little while (ie. no output in "ps aux | grep gnome-screensaver")?
Error message dialog doesn't appear in the startup. 


> If so, that would mean that gnome-screensaver is crashing, and it's a problem

> with gnome-screensaver.

Is gnome-screensaver crashing? I don't know that.  I know that
gnome-screensaver doesn't luanch in startup.

Comment 10 sangu 2007-06-20 04:14:39 UTC
After installing 2.19.4-3.fc8 ( see also bug 244843 ), error dialog  shows

"There was an error starting up the screensaver
Failed to execute child process "gnome-screensaver (No such file or directory)
Screensaver functionality will not work in this session."

$ rpm -qf /usr/bin/gnome-screensaver
gnome-screensaver-2.19.1.1-1.fc8

Comment 11 Matthias Clasen 2007-06-21 04:54:41 UTC
Fixed in control-center-2.19.4-4.fc8


Note You need to log in before you can comment on or make changes to this bug.