Bug 243593 - gutenprint-plugin not installed when gimp is
gutenprint-plugin not installed when gimp is
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-10 06:47 EDT by Tim Waugh
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.2.15-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 21:53:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-06-10 06:47:03 EDT
Description of problem:
The gutenprint-plugin package should be installed whenever gimp is installed. 
It provides the File->Print... menu item.
Comment 1 Jesse Keating 2007-06-10 08:09:55 EDT
Hrm, didn't we go over this previously?  You had some comps issues with these
packages, I reported that I made the package optional in the group that gimp was
in and that was fine then.  If it should be installed whenever gimp is
installed, then gimp should just Require it no?
Comment 2 Jesse Keating 2007-06-12 16:14:38 EDT
ping?
Comment 3 Tim Waugh 2007-06-13 04:14:43 EDT
I remember now.  We removed the 'Requires: gimp-print-plugin' line from
gimp.spec in order to stop pulling in gimp-print, but we couldn't add 'Requires:
gutenprint-plugin' because the merge hadn't happened at that time.

Perhaps we just need to add 'Requires: gutenprint-plugin'.  Changing component
to gimp and reassigning.
Comment 4 Nils Philippsen 2007-06-13 04:50:44 EDT
Hmm, this is one place where "Suggests:" would be really helpful.

Anyway, since neither gutenprint-plugin nor gutenprint pull in extraordinary
stuff, I'll put it into the spec file. I won't rebuild it now for F7 though
(will do for Rawhide), as anybody who encounters the problem probably has
installed the plugin already by now and the package's size is just prohibitive
for such a small issue.

So this will only go out with an update for something else on F7, but mind that
we might have to revisit it anyway as somebody is just bound to pop up who feels
that this requirement isn't needed ;-).
Comment 5 Tim Waugh 2007-06-13 04:55:24 EDT
Thanks.
Comment 6 Fedora Update System 2007-06-27 21:53:03 EDT
gimp-2.2.15-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Gene Heskett 2007-06-30 22:33:49 EDT
Please put gutenprint in core and make gimp-print go away for starters.

Second, hard coding the most recent core 6 gimp update to require gimp-print,
simply doesn't grok.

There are _no_ real dependencies in gimp that require either helper program to
be installed, none, nada.  Please remove them and release a new gimp so that
those of us who refuse to let that ancient, broken gimp-print-4.2.7's Epson
drivers anywhere near our printers can use it with gutenprint.

You now have me between a rock and a hard place, I would like to update my gimp
install _using_ the package manager, but I cannot because it will drag in
gimp-print, very carefully destroying the quality of my printouts because the
epson drivers were heavily updated back in Februrary of this year, and I first
built gutenprint-5.10 from a tarball, then rebuilt it using checkinstall, and
reinstalled it so at least the rpm database was aware that gutenprint is installed.

The current situation has me running smart to see what can be updated, making
notes and cancelling that update, then have it install 3 or 4 of the other
updates, repeat until I run out of updates other than gimp, which will drag in
and re-install gimp-print and its plugin which I removed in Februrary.  With the
bugfixes that are in gutenprint, re-installing gimp-print, an un-maintained
program for the last 2 years, simply is not going to happen.

Gimp doesn't need to have deps to either program, it really is that simple. 
Remove them.

Comment 8 Nils Philippsen 2007-07-03 06:47:43 EDT
Gene, you could just rebuild the gutenprint package from F7. Its
gutenprint-plugin sub-package provides "gimp-print-plugin = 4.2.7-25" so yum
won't drag in the real gimp-print-plugin package from updates anymore.

As there are no "soft" requirements in RPM, I can choose between a) not having a
requirement on the print plugin and people finding they can't print with GIMP if
it's not installed or b) having the requirement and people not wanting to print
having to install a measly 5MB alongside with GIMP. I chose b) because I suppose
these people are far less numerous than those of a) would be.
Comment 9 Gene Heskett 2007-07-03 09:11:17 EDT
What version is that gutenprint?  

Why not give us the choice?  This lock-in is worse than M$ has done.  Maybe its
time rpm was worked on again?

2. configuring my smart or yum to pull from the f7 srcs I can probably do, and
then trying to rebuild that rpm is something I have never been able to make
work, and like teaching pigs to sing, annoys the pig (in this case me) no end.

When this situation occurred for FC2 and it became apparent that fedora was NOT
going to fix it regardless of the kde users mewling about it, I found it far far
easier to just get the tarball, unpack it, ./configure;make;make install, or in
the case of kde's konstruct, follow its directions, which just worked as long as
all its url's were available.

Lately I've been using checkinstall, but it comes with its own set of foibles &
gotcha's, and I don't know enough about writing .spec files to make it tell rpm
that this replaces gimp-print.  I've not managed to find a tutorial on writing
spec files, so that's all a big proprietary secret to me.  If there is such a
beast, please advise of its url.

I also don't appreciate being treated as part of the problem when I didn't
create the problem.  People who notice the print option missing and ask can be
told to install one or the other, and your choice to stick with 3 year old code
and totally disallow the 'other' far better alternate, insults the users
intelligence by treating us all as sheeple like proprietary stuff does.
Comment 10 Nils Philippsen 2007-07-03 10:56:36 EDT
(In reply to comment #9)
> What version is that gutenprint?  

nils@gibraltar:~> rpm -q gutenprint-plugin
gutenprint-plugin-5.0.0.99.1-3.fc7

> Why not give us the choice?  This lock-in is worse than M$ has done.

Don't get personal.

>  Maybe its
> time rpm was worked on again?

Go ahead :-).

> 2. configuring my smart or yum to pull from the f7 srcs I can probably do, and
> then trying to rebuild that rpm is something I have never been able to make
> work, and like teaching pigs to sing, annoys the pig (in this case me) no end.
> 
> When this situation occurred for FC2 and it became apparent that fedora was NOT
> going to fix it regardless of the kde users mewling about it, I found it far far
> easier to just get the tarball, unpack it, ./configure;make;make install, or in
> the case of kde's konstruct, follow its directions, which just worked as long as
> all its url's were available.
> 
> Lately I've been using checkinstall, but it comes with its own set of foibles &
> gotcha's, and I don't know enough about writing .spec files to make it tell rpm
> that this replaces gimp-print.  I've not managed to find a tutorial on writing
> spec files, so that's all a big proprietary secret to me.  If there is such a
> beast, please advise of its url.

Google for "Maximum RPM". It's a tad old, i.e. it doesn't know about some of the
newer, more esoteric constructs like "%posttrans", but that shouldn't concern
you. It should teach you how to unpack the source RPM ("rpm -i ..."), where the
sources go to, how to define a new requirement and how to build binary packages
from that. Checkinstall is only a band-aid and if you want to modify an
RPM-based distribution, dealing with RPM-building kinda comes bundled with it.

> I also don't appreciate being treated as part of the problem when I didn't
> create the problem.  People who notice the print option missing and ask can be
> told to install one or the other, and your choice to stick with 3 year old code

As nobody seemed to volunteer answering these questions for me, I thought it was
better for my sanity to require the print plugin (which happened to come from
gimp-print in FC6) rather than answering these questions again and again. I
can't comment on why FC6 shipped with gimp-print rather than gutenprint. Tim?

> and totally disallow the 'other' far better alternate, insults the users
> intelligence by treating us all as sheeple like proprietary stuff does.

Again, don't get insulting. Using gutenprint as a drop-in replacement is
entirely possible, a simple rebuild of the F7 source RPM on FC6 should be
sufficient.
Comment 11 Tim Waugh 2007-07-03 11:51:18 EDT
(In reply to comment #10)
> gimp-print in FC6) rather than answering these questions again and again. I
> can't comment on why FC6 shipped with gimp-print rather than gutenprint. Tim?

As at one year ago the latest stable release was gimp-print-4.2.7.  Gutenprint
5.0.0, its first stable release, was announced on July 30th 2006.  By that time
our resources for Fedora Core 6 were spoken (the system-config-printer rewrite),
but an Extras package was made available after release.

Note You need to log in before you can comment on or make changes to this bug.