Bug 243612 - logwatch wrong packages updates
logwatch wrong packages updates
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-10 14:51 EDT by Need Real Name
Modified: 2014-01-21 17:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 17:58:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-06-10 14:51:29 EDT
I have FC4 running Logwatch 7.3.6 (05/19/07)
today I got a report that the packages are updated 
(see below). But they actually were updated 09 Jun 2006 (one year ago),
not 09 June 2007 (yesterday). Is there a but with year processing in logwatch?

--------------------- yum Begin ------------------------ 
 
 Packages Updated:
    tetex-dvips.i386 3.0-10.FC4
    tetex-latex.i386 3.0-10.FC4
    tetex-xdvi.i386 3.0-10.FC4
    tetex-afm.i386 3.0-10.FC4
    tetex.i386 3.0-10.FC4
    tetex-fonts.i386 3.0-10.FC4
-------------------------------------------------
rpm -qa --last |grep tetex
tetex-xdvi-3.0-10.FC4                         Fri 09 Jun 2006 01:59:12 PM EDT
tetex-afm-3.0-10.FC4                          Fri 09 Jun 2006 01:59:10 PM EDT
tetex-latex-3.0-10.FC4                        Fri 09 Jun 2006 01:58:33 PM EDT
tetex-3.0-10.FC4                              Fri 09 Jun 2006 01:58:21 PM EDT
tetex-dvips-3.0-10.FC4                        Fri 09 Jun 2006 01:57:57 PM EDT
tetex-fonts-3.0-10.FC4                        Fri 09 Jun 2006 01:57:31 PM EDT
Comment 1 Need Real Name 2007-06-10 14:52:52 EDT
################### Logwatch 7.3.6 (05/19/07) #################### 
        Processing Initiated: Sun Jun 10 04:02:11 2007
        Date Range Processed: yesterday
                              ( 2007-Jun-09 )
                              Period is day.
      Detail Level of Output: 0
              Type of Output: unformatted
           Logfiles for Host: mserver
  ################################################################## 
Comment 2 Need Real Name 2007-06-10 14:57:12 EDT
The problem is that yum log does not have a year specified
what confuses logwatch and probably other programs.
This is a problem with yum, which I believe should be fixed

/var/log/yum.log
Jun 09 13:57:57 Updated: tetex-fonts.i386 3.0-10.FC4
Jun 09 13:58:11 Updated: tetex-dvips.i386 3.0-10.FC4
Jun 09 13:58:25 Updated: tetex.i386 3.0-10.FC4
Jun 09 13:59:06 Updated: tetex-latex.i386 3.0-10.FC4
Jun 09 13:59:12 Updated: tetex-afm.i386 3.0-10.FC4
Jun 09 13:59:13 Updated: tetex-xdvi.i386 3.0-10.FC4
Comment 3 Ivana Varekova 2007-06-11 03:57:57 EDT
Logwatch can't recognize in which year the event have happand from yum log so
this bug have to be fixed in yum at first. I'm reassigning this bug to yum.
Comment 4 Seth Vidal 2007-08-29 17:58:34 EDT
log watch should stop watching the yum log and just watch the system logs - yum
ouptuts there in a format it is more likely to like.

Note You need to log in before you can comment on or make changes to this bug.