This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 243628 - xtide font crash
xtide font crash
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-fonts (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-10 18:18 EDT by Tom
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version: 2.9.3-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 11:40:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom 2007-06-10 18:18:28 EDT
Description of problem:I recently upgraded my system to Fedora Core 7. I was
running Xtide on FC6 without a problem, but now, when I run xtide, I get the
following output in the terminal, with no Xtide starting:

XTide Fatal Error:  CANT_LOAD_FONT
A font that is required by XTide does not appear on the system.
Perhaps there is an optional font package that you need to install.

Error details:
-misc-fixed-medium-r-normal--13-100-100-100-c-70-iso8859-1


Version-Release number of selected component (if applicable):Version 2.9.3
Release      1.fc7.1


How reproducible:start xtide in terminal window


Steps to Reproduce:
1.in terminal window, enter "xtide"
2.
3.
  
Actual results:xtide does not start


Expected results:xtide starts


Additional info:
Comment 1 Tom 2007-06-10 18:19:49 EDT
I believe the font is properly installed in my system, and I am not having any
font problems with any other application
Comment 2 Tom 2007-06-10 19:16:57 EDT
the above version and release info is for xtide.
Comment 3 Tom 2007-06-11 07:55:52 EDT
I received a reply from Dave Flater, the developer and Mamoru Tasaka, who must
have ported xtide for fc7 and Mamoru said:

"Would you try xtide-2.9.3-3.fc7? 
Currently the rpms are under: 
http://koji.fedoraproject.org/packages/xtide/2.9.3/3.fc7/ 
I explicitly added xorg-x11-fonts-base to Requires."

I removed xtide 2.9.3-1fc7 (which did not list xorg-x11-fonts-base as a
dependency) and installed xtide 2.9.3-3fc7 and it properly asked for
xorg-x11-fonts-base, which I installed and after a reboot, xtide works just
fine. The latest version, xtide 2.9.3-3fc7 needs to replace the current version
in the repositories for Fedora and Freshrpms. 
Once the new version is placed in the repositories, this bug can be closed.
thanks,
Tom
Comment 4 Matěj Cepl 2007-06-13 11:24:52 EDT
What is the output of this command

rpm -qf `find /usr/share/fonts/ -name fonts.dir \
-exec grep -l -- '-misc-fixed-medium' '{}' \;`

THanks

Note You need to log in before you can comment on or make changes to this bug.