Bug 243645 - autofs doesn't permit "." in macro or macro value
autofs doesn't permit "." in macro or macro value
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 04:18 EDT by Ian Kent
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0621
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:56:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to premit "." in macro define and value (480 bytes, patch)
2007-06-11 04:18 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Description Ian Kent 2007-06-11 04:18:31 EDT
Description of problem:
autofs does not allow macro defines in the master map don't
allow the macro name or it's value to contain a ".".

How reproducible:
Always.

Steps to Reproduce:
1 . Add the following to the master map:
/test   /etc/auto.define -DDIR.DOT=test.dot

2. Add the following to /etc/auto.define:
def     :/usr/local/tmp/${DIR.DOT}

3. Create the directory /usr/local/tmp/test.dot

4. Attempt to automount /test/def with:
ls /test/def

Actual results:
the ls returns:
ls: /test/def: No such file or directory

Expected results:
ls returns after successful mount.
Comment 1 Ian Kent 2007-06-11 04:18:31 EDT
Created attachment 156683 [details]
Patch to premit "." in macro define and value
Comment 2 Ian Kent 2007-06-11 04:20:06 EDT
This is a regression wrt version 4 behaviour.
Comment 3 RHEL Product and Program Management 2007-06-11 04:24:03 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 RHEL Product and Program Management 2007-06-11 04:26:39 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 5 Ian Kent 2007-06-22 05:11:54 EDT
A correction for this issue is present in revision
autofs-5.0.1-0.rc2.50.
Comment 10 errata-xmlrpc 2007-11-07 12:56:15 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0621.html

Note You need to log in before you can comment on or make changes to this bug.