Bug 243646 - Unable to modify logical partition (or_IN)
Summary: Unable to modify logical partition (or_IN)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-lvm   
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Marek Grac
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-11 08:27 UTC by subhransu behera
Modified: 2016-04-26 14:26 UTC (History)
6 users (show)

Fixed In Version: system-config-lvm-1.1.5-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 08:42:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (514 bytes, patch)
2009-08-17 12:12 UTC, Marek Grac
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0267 normal SHIPPED_LIVE system-config-lvm bug fix update 2010-03-29 12:54:55 UTC

Description subhransu behera 2007-06-11 08:27:19 UTC
Description of problem:

Unable to modify logical partition while selecting it from system-config-lvm.

Version-Release number of selected component (if applicable):

system-config-lvm-1.0.22-1.0.el5
gtk+-1.2.10-56.el5
gtk2-2.10.4-16.el5
gtk2-devel-2.10.4-16.el5

How reproducible:
Run system-config-lvm and view logical partition. Try to edit properties.
Nothing is done while clicking okay.

Steps to Reproduce:
1. Select system-config-lvm from System-> Administration -> Logical Volume
Management.

2. Select logical view and try editing any of the logical partitions.

3. After modifying the LV size and clicking on okay button nothing is done.
  
Actual results:

Nothing is done. The LV size is not changed.

Expected results:

It should save the settings and the LV partition should be changed to the
desired size (if available).

Additional info:

While running system-config-lvm from terminal it displaye the following error
message: 

*****************************************************************
[root@sbehera ~]# system-config-lvm 
Traceback (most recent call last):
  File "/usr/share/system-config-lvm/InputController.py", line 1048, in on_edit_lv
    if dlg.run() == False:
  File "/usr/share/system-config-lvm/InputController.py", line 1338, in run
    if self.apply() == True:
  File "/usr/share/system-config-lvm/InputController.py", line 1913, in apply
    stripe_size = int(stripe_size_combo.get_model().get_value(iter, 0))
ValueError: invalid literal for int(): ୪
*****************************************************************

It seems like a broken translated strings. Hence, the specific strings have been
modified and the translation is being committed to the cvs.

Comment 1 subhransu behera 2007-06-11 08:30:58 UTC
The above bug is for Oriya language only. It gives error only when the system's
default language Oriya (or_IN).

Comment 2 Red Hat Bugzilla 2008-07-16 05:29:08 UTC
Adding sankar@redhat.com to the cc list as the manager of the disabled user sbehera@redhat.com who reported this bug

Comment 3 Marek Grac 2009-08-07 15:10:27 UTC
Problem located. In or_IN also numbers are translated to local glyphs and combo box does not expect it. So it is not a problem of translation

Comment 4 Marek Grac 2009-08-17 12:12:40 UTC
Created attachment 357641 [details]
Proposed patch

If you attempt to create new logical volume (LC_ALL=or_IN) there are some   
other boxes that shows numbers in arabic glyphs. Proposed patch unmark those 
numbers as translatable. 

If you believe that there should be non-arabic numbers, let me know.

Comment 5 Ankit Patel 2009-08-17 12:29:02 UTC
Removing sankar@redhat.com and adding myself and mgiri@redhat.com, who's in my team and in charge of taking care of Oriya Language translations. Please let's know, if there is something to do with translation/localization.

Thanks!
Ankit

Comment 8 Brian Brock 2010-03-08 20:13:09 UTC
system-config-lvm-1.1.5-4.el5 seems to be fixed, I can change various components of an lv and those changes are reflected immediately.

Comment 10 errata-xmlrpc 2010-03-30 08:42:49 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0267.html


Note You need to log in before you can comment on or make changes to this bug.