Bug 243647 - Consistent error when creating virtual machine
Consistent error when creating virtual machine
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 04:29 EDT by John Lagrue
Modified: 2008-01-10 23:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 23:10:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Lagrue 2007-06-11 04:29:49 EDT
Description of problem:

After creating a VM disk as a single file I get this error:
Unable to complete install '<class 'libvirt.libvirtError'>
virDomainCreateLinux() failed internal error Timed out while reading monitor
startup output
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 681, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 649, in
start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 666, in
_do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 480, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed internal error Timed out while
reading monitor startup output


Version-Release number of selected component (if applicable):
Current version with f7

How reproducible:
Every time I create a new VM

Steps to Reproduce:
1.Follow wizard
2.Guest OS type does not make any difference
3.
  
Actual results:
Machine is created, if the error is ignred.

Expected results:


Additional info:
Comment 1 Daniel Berrange 2007-06-11 17:25:10 EDT
A new libvirt release 0.2.3-1.fc7 will shortly be available in Fedora 7
Updates-testing yum repository. Please upgrade to this version when available,
run 'service libvirtd restart' and then try to create the virtual machine again.
This should give you improved error reporting in the UI, and failing that also
create a log file in /var/log/libvirt/ with full info.
Comment 2 Michal Klich 2007-07-12 02:34:50 EDT
I am having same error with libvirt-0.3.0-1.fc7. I tried to create virtual
machine out of Kde4Live and then Win Xp Home Sp2. Both gave me same error. I
dont have log file, directory you provided is empty.

Error message:

Unable to complete install '<class 'libvirt.libvirtError'>
virDomainCreateLinux() failed operacja POST nie powiodła się: (xend.err 'Device
768 (vbd) could not be connected.
/home/InIrudeBwoy/Publiczne/WinXP_Home_SP2_ENG/VMWinXPHomeSP2 does not exist.')
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 681, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 649, in
start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 666, in
_do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 521, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed operacja POST nie powiodła się:
(xend.err 'Device 768 (vbd) could not be connected.
/home/InIrudeBwoy/Publiczne/WinXP_Home_SP2_ENG/VMWinXPHomeSP2 does not exist.')
Comment 3 Daniel Veillard 2007-07-12 03:47:23 EDT
Error from #2 seems completely unrelated to this bug. As the log shows
the /home/InIrudeBwoy/Publiczne/WinXP_Home_SP2_ENG/VMWinXPHomeSP2 path
specified for the install is not found by Xen when starting the domain.

Can the author of the bug report check with package libvirt-0.3.0-1.fc7
available in Testing ? Make sure to stop libvirtd service before the
upgrade and restart it after, or simply reboot the machine after the
upgrade to make sure the new daemon is in use.

Daniel
Comment 4 Red Hat Bugzilla 2007-07-24 22:13:12 EDT
change QA contact
Comment 5 Daniel Berrange 2008-01-10 23:10:51 EST
Most likely blocked by SELinux since the file was under /home instead of
/var/lib/xen/images. Please re-open if this wasn't the problem & you have the
info reuqest from comment #3.

Note You need to log in before you can comment on or make changes to this bug.