Bug 243693 - selinux blocks dovecot writing to nfs_t with use_nfs_home_dirs=1
Summary: selinux blocks dovecot writing to nfs_t with use_nfs_home_dirs=1
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy-targeted   
(Show other bugs)
Version: 5.0
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-11 13:21 UTC by Andy Schofield
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0544
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 16:39:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0544 normal SHIPPED_LIVE selinux-policy bug fix update 2007-11-08 14:16:49 UTC

Description Andy Schofield 2007-06-11 13:21:11 UTC
Description of problem:
The dovecot imap server is denied write access to users Maildir which are
automounted over NFS. setroubleshoot suggests "setsebool -P use_nfs_home_dirs=1"
which has been done but makes no difference. Also setting 
"dovecot_disable_trans=1" does not make any difference.

Version-Release number of selected component (if applicable):
selinux-policy-2.4.6-30.el5
dovecot-1.0-1.2.rc15.el5
selinux-policy-targeted-2.4.6-30.el5


How reproducible:
Always

Steps to Reproduce:
1. Configure dovecot with mail_location = maildir:~/Maildir
2. NFS used to mount home directories on dovecot server: context is nfs_t
3. Use selinux in enforcing mode with policy targeted
4. setsebool -P use_nfs_home_dirs=1
5. Connect to dovecot server using a mail client and attempt to delete an email.
 
Actual results:
avc: denied { write } for comm="imap" dev=0:16 egid=600 euid=1000
exe="/usr/libexec/dovecot/imap" exit=-13 fsgid=600 fsuid=1000 gid=600 items=0
name="cur" pid=5500 scontext=user_u:system_r:dovecot_t:s0 sgid=600
subj=user_u:system_r:dovecot_t:s0 suid=1000 tclass=dir
tcontext=system_u:object_r:nfs_t:s0 tty=(none) uid=1000 


Expected results:
File to be moved to Trash

Additional info:
I am using NFS4 but get same behaviour with NFS3.

Comment 1 Daniel Walsh 2007-06-11 14:27:14 UTC
Fixed in selinux-policy-2.4.6-75

Comment 2 RHEL Product and Program Management 2007-06-11 14:33:51 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Eduard Benes 2007-08-22 15:15:46 UTC
Could you try the new policy available at the link below and reply 
whether the new packages solve your problem. 

http://people.redhat.com/dwalsh/SELinux/RHEL5/noarch/

Comment 7 Andy Schofield 2007-10-01 22:02:14 UTC
Seems to be fixed in 2.4.6-98 - thanks

Comment 9 errata-xmlrpc 2007-11-07 16:39:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0544.html



Note You need to log in before you can comment on or make changes to this bug.