Bug 243748 - Cannot specify/select mail file for Local Delivery settings
Cannot specify/select mail file for Local Delivery settings
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
:
: 250739 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 13:58 EDT by Marc Schwartz
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 18:27:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 352346 None None None Never

  None (edit)
Description Marc Schwartz 2007-06-11 13:58:03 EDT
Description of problem:

This is after a clean install of F7, though /home was preserved.

When attempting to modify some settings in my e-mail account, I suddenly started
getting errors from the application indicating that '/var/spool/mail' is a folder.

I use fetchmail/postfix/amavis to retrieve e-mail from several accounts into a
local e-mail spool file and filter spam, etc.

In going back into the settings, I noted that when selecting any of the options,
where one would select a mail file (ie. /var/spool/mail/marcs) using Local
Delivery, one can only select folders, not files. Thus, Evo is trying to
retrieve mail from a folder, rather than the spool file.

I ended up going into GConf to manually modify the folder setting and can now
access my e-mail spool file.


Version-Release number of selected component (if applicable):

2.10.2


How reproducible:

Always


Steps to Reproduce:

1. Go into Evo and either setup or modify an existing e-mail account that uses
   Local Delivery.

2. Try to select the user account spool file.

3. You can only select '/var/spool/mail'

  
Actual results:

As Above.


Expected results:

Should be able to define specific user spool file.


Additional info:

Work around is to use GConf or go into the XML file directly and modify the
setting for the spool file for the account (~/.gconf/apps/evolution/mail/%gconf.xml)
Comment 1 Matthew Barnes 2007-06-11 18:27:35 EDT
Thanks for the bug report.  This is a known problem and the upstream developers
are working to fix it.  I'm going to close this bug and refer you to the
upstream bug already in progress.  Please refer to [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=352346
Comment 2 Matthew Barnes 2007-08-03 08:28:11 EDT
*** Bug 250739 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.