Bug 243784 - sub-mount maps do not work in autofs v5
sub-mount maps do not work in autofs v5
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 17:20 EDT by Jeffrey Moyer
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 08:29:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Moyer 2007-06-11 17:20:13 EDT
Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc2.46

How reproducible:
100%

Steps to Reproduce:
# cat /etc/auto.master
/test   /etc/auto.test --debug

# cat /etc/auto.test
sub     -fstype=autofs /etc/auto.sub

# cat /etc/auto.sub
*       localhost:/export/&

Default /etc/sysconfig/autofs, default /etc/nsswitch.conf.

It seems like parse_sun no longer deals with submount maps properly.
Here is the debug log:

automount[9321]: master_do_mount: mounting /test
automount[9321]: lookup_nss_read_map: reading map file /etc/auto.test
automount[9321]: handle_packet: type = 3
automount[9321]: handle_packet_missing_indirect: token 7, name sub, request pid 9331
automount[9321]: lookup_mount: lookup(file): looking up sub
automount[9321]: lookup_mount: lookup(file): sub -> -fstype=autofs /etc/auto.sub
automount[9321]: parse_mount: parse(sun): expanded entry: -fstype=autofs
/etc/auto.sub
automount[9321]: parse_mount: parse(sun): gathered options: fstype=autofs
automount[9321]: parse_mount: parse(sun): dequote("/etc/auto.sub") -> /etc/auto.sub
automount[9321]: parse_mapent: parse(sun): gathered options: fstype=autofs
automount[9321]: parse_mapent: parse(sun): invalid location
automount[9321]: handle_packet: type = 3
automount[9321]: handle_packet_missing_indirect: token 8, name sub, request pid 9331
automount[9321]: lookup_mount: lookup(file): looking up sub
automount[9321]: master_notify_state_change: sig 15 switching /test from 1 to 5
automount[9321]: st_prepare_shutdown: state 1 path /test
automount[9321]: expire_proc: exp_proc = 1084385600 path /test
automount[9321]: expire_cleanup: got thid 1084385600 path /test stat 0
automount[9321]: expire_cleanup: sigchld: exp 1084385600 finished, switching
from 5 to 7
automount[9321]: umount_multi: path /test incl 0
Comment 1 Ian Kent 2007-06-11 23:37:57 EDT
Yes, I see.
Obviously we let this through in version 4.

Strictly speaking the location requires a ":" because
it begins with a "/". The connectathon submount tests
all have a colon in front of the path location and have
always been like that since I started working with it.

I'm not sure what should be done here as allowing this
has other side affects such as being able to reliably
identify a multi-mount.

Ian
Comment 2 Jeffrey Moyer 2007-06-12 08:29:07 EDT
Actually, in the view autofs v4 versions I've tested, they don't allow this
either!  So, this is not a bug.  Submount maps that supply an explicit path
require a : escape, just like everyone else.

Sorry for the noise!

Note You need to log in before you can comment on or make changes to this bug.