Bug 243789 - anaconda crashes "string index out of range" on FC7 upgrade
anaconda crashes "string index out of range" on FC7 upgrade
Status: CLOSED DUPLICATE of bug 241991
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 17:53 EDT by mark hewitt
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 09:56:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump file writen to floopy (lucky I had one) during install. (96.55 KB, text/plain)
2007-06-11 17:53 EDT, mark hewitt
no flags Details

  None (edit)
Description mark hewitt 2007-06-11 17:53:00 EDT
Description of problem:

DVD based upgrade of FC7 (from FC6) fails with crash "String index out of range"
in anaconda.


How reproducible:

Hard error.

Dump attached.



Steps to Reproduce:
1. Just start DVD upgrade.  After selecting keyboard etc, anaconda crashes.
Comment 1 mark hewitt 2007-06-11 17:53:00 EDT
Created attachment 156761 [details]
Dump file writen to floopy (lucky I had one) during install.
Comment 2 mark hewitt 2007-06-12 02:29:02 EDT
This is caused by blank lines in /etc/modprobe.conf of which anaconda is
intollerant.  Therefore, the workaround is pretty straightforward.
Comment 3 Chris Lumens 2007-06-12 09:56:46 EDT

*** This bug has been marked as a duplicate of 241991 ***

Note You need to log in before you can comment on or make changes to this bug.