Bug 243798 - hub_port_status_failed (err = -71) message triggered by fingerprint reader
Summary: hub_port_status_failed (err = -71) message triggered by fingerprint reader
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-11 22:57 UTC by Dawid Zamirski
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 2.6.21-1.3255.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 22:12:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cat /sys/kernel/debug/usbmon/2t > /home/maners/1.mon.out (59.34 KB, text/plain)
2007-06-12 01:00 UTC, Dawid Zamirski
no flags Details

Description Dawid Zamirski 2007-06-11 22:57:54 UTC
Description of problem:
I was trying to configure my fingerprint reader on Dell Latitude D820N with
thinkfinger and the tf-tool was unable to find the usb device. After playing
with it a bit, I found that, once the USB port is scanned, the device connects
and disconnects itself immediately with hub_port_status_failed message in the
logs. For the short period of time, before it disconnects itself, the device
seems to function properly. I have recorded a short movie to better illustrate
the problem:

http://maners.no-ip.com/usb.ogg


Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3194.fc7
thinkfinger-0.2.2-4.fc7

How reproducible:
Always

Steps to Reproduce:
1. run tf-tool as root
2. USB device not found
3. run tf-tool again quicly after previous attempt, device is detected
4. wait about 2s and it's gone again.
  
Actual results:
Device works for a very short (1-2s) period of time then disconnects itself.

Expected results:
Device should remain connected and working all the time.

Comment 1 Pete Zaitcev 2007-06-11 23:15:15 UTC
David, would you be so kind to capture me a usbmon trace too? It will show
after what command exactly the device disconnects. There's a HOWTO here:
 /usr/share/doc/kernel-doc-2.6.21/Documentation/usb/usbmon.txt
I hope it's not too difficult to follow.

Please attach the trace to the bug as a file.


Comment 2 Pete Zaitcev 2007-06-11 23:16:48 UTC
Mental note: The odd thing is that -71 occured for a HUB, not for a DEVICE.


Comment 3 Dawid Zamirski 2007-06-11 23:53:22 UTC
Sure, but usbmon doesn't seem to be included in any Fedora package. I tried yum
provides usbmon and yum provides /*usbmon* and also installed kernel-debug and
kernel-debug-debuginfo pakcages in hope that they will contain usbmon module but
modprobe usbmon still says "Module usbmon not found"

Comment 4 Pete Zaitcev 2007-06-12 00:24:49 UTC
The usbmon is a kernel module's name, it interfaces with cat(1).
So, there's no need to install anything (except kernel-doc).
The modprobe says that it's not found because the module is linked
into the kernel statically. Once you have mounted debugfs, the
mount point should contain usbmon subdirectory. Usually you mount
on /sys/kernel/debug.

Comment 5 Dawid Zamirski 2007-06-12 01:00:11 UTC
Created attachment 156773 [details]
cat /sys/kernel/debug/usbmon/2t > /home/maners/1.mon.out

Thanks, so I ahve attacheed the output of the device (it seems to be on Bus=002
hence I used 2t debug device). The output was generated after the following
sequence:

[root@laptop ~]# tf-tool --verify

ThinkFinger 0.2.2 (http://thinkfinger.sourceforge.net/)
Copyright (C) 2006, 2007 Timo Hoenig <thoenig@suse.de>

Initializing...USB device not found.
[root@laptop ~]# tf-tool --verify

ThinkFinger 0.2.2 (http://thinkfinger.sourceforge.net/)
Copyright (C) 2006, 2007 Timo Hoenig <thoenig@suse.de>

Initializing... done.
Please swipe your finger (successful swipes 1/1, failed swipes: 0)... done.
Result: Fingerprint does match.
[root@laptop ~]# tf-tool --verify

ThinkFinger 0.2.2 (http://thinkfinger.sourceforge.net/)
Copyright (C) 2006, 2007 Timo Hoenig <thoenig@suse.de>

Initializing... done.
Please swipe your finger (successful swipes 1/1, failed swipes: 0)... done.
Result: Fingerprint does match.
[root@laptop ~]# tf-tool --verify

ThinkFinger 0.2.2 (http://thinkfinger.sourceforge.net/)
Copyright (C) 2006, 2007 Timo Hoenig <thoenig@suse.de>

Initializing...USB device not found.
[root@laptop ~]# tf-tool --verify

ThinkFinger 0.2.2 (http://thinkfinger.sourceforge.net/)
Copyright (C) 2006, 2007 Timo Hoenig <thoenig@suse.de>

Initializing...USB device not found.
[root@laptop ~]# tf-tool --verify

ThinkFinger 0.2.2 (http://thinkfinger.sourceforge.net/)
Copyright (C) 2006, 2007 Timo Hoenig <thoenig@suse.de>

Initializing... done.
Please swipe your finger (successful swipes 1/1, failed swipes: 0)... done.
Result: Fingerprint does match.
[root@laptop ~]# 

I hope this info is helpful. Thanks again for guidance!

Comment 6 Pete Zaitcev 2007-06-20 21:41:59 UTC
Yes, it was very helpful.

I'm going to dup this bug into bug 239507, they seem to be truly for
the same problem, judging from usbmon results.

Comment 7 Dawid Zamirski 2007-07-16 21:56:23 UTC
Hello

After installing the kernel-2.6.21-1.3255.fc7 from updates-testing the problem
went away and the fingerprint authentication is working. There's no
errors/warnings in the system log.

Comment 8 Pete Zaitcev 2007-07-16 22:12:56 UTC
Disabling the auto-suspend fixed this bug. I don't know why, but the
built-in hub dies if suspeneded.

I think I'll close this for now.



Note You need to log in before you can comment on or make changes to this bug.