Bug 243805 - SELinux is preventing /lib/ld-2.6.so (prelink_t) "execute" to /usr/games/viruskiller (usr_t).
SELinux is preventing /lib/ld-2.6.so (prelink_t) "execute" to /usr/games/viru...
Status: CLOSED DUPLICATE of bug 243031
Product: Fedora
Classification: Fedora
Component: viruskiller (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-06-11 19:52 EDT by Jim Cornette
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-12 04:24:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2007-06-11 19:52:19 EDT
Description of problem:

Version-Release number of selected component (if applicable):

glibc-2.6-3 [application]viruskiller-1.0-3.fc7 [target]

How reproducible:

SELinux denied access requested by /lib/ld-2.6.so. It is not expected that this
access is required by /lib/ld-2.6.so and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Additional info:

Source Context:  system_u:system_r:prelink_tTarget
Context:  system_u:object_r:usr_tTarget Objects:  /usr/games/viruskiller [ file
]Affected RPM Packages:  glibc-2.6-3 [application]viruskiller-1.0-3.fc7
[target]Policy RPM:  selinux-policy-2.6.4-13.fc7Selinux Enabled:  TruePolicy
Type:  targetedMLS Enabled:  TrueEnforcing Mode:  EnforcingPlugin
Name:  plugins.catchall_fileHost Name:  HP-JCF7Platform:  Linux HP-JCF7
2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:35:01 EDT 2007 i686 athlonAlert
Count:  6First Seen:  Mon 04 Jun 2007 07:01:52 PM EDTLast Seen:  Mon 11 Jun 2007
07:25:42 PM EDTLocal ID:  ec620783-90f6-4af0-8cc3-5a9bb148d9cb

Line Numbers:  Raw Audit Messages :avc: denied { execute } for
comm="ld-linux.so.2" dev=sda6 egid=0 euid=0 exe="/lib/ld-2.6.so" exit=-13
fsgid=0 fsuid=0 gid=0 items=0 name="viruskiller" path="/usr/games/viruskiller"
pid=5691 scontext=system_u:system_r:prelink_t:s0 sgid=0
subj=system_u:system_r:prelink_t:s0 suid=0 tclass=file
tcontext=system_u:object_r:usr_t:s0 tty=(none) uid=0 

Information obtained through setroubleshoot browser
Comment 1 Matthias Saou 2007-06-12 04:24:14 EDT
This will be fixed by moving the games' files to /usr/bin/ and /usr/share/.

*** This bug has been marked as a duplicate of 243031 ***

Note You need to log in before you can comment on or make changes to this bug.