Bug 243813 - Evolution crashes when trying to open date picker
Evolution crashes when trying to open date picker
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Crha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 23:15 EDT by Bojan Smojver
Modified: 2008-03-08 17:18 EST (History)
3 users (show)

See Also:
Fixed In Version: evolution2.12.0-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 07:00:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace (8.59 KB, text/plain)
2007-06-11 23:15 EDT, Bojan Smojver
no flags Details

  None (edit)
Description Bojan Smojver 2007-06-11 23:15:06 EDT
Description of problem:
Evolution crashes when picking date required for search.

Version-Release number of selected component (if applicable):
2.10.2-2.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Right click on the search and pick Advanced Search..
2. When the dialog opens, select Date Sent in the field selection.
3. Then click on <click here to select date>.
  
Actual results:
Evolution crashes.

Expected results:
Didn't crash in FC6 at least.

Additional info:
Attached is backtrace of the crash.
Comment 1 Bojan Smojver 2007-06-11 23:15:06 EDT
Created attachment 156774 [details]
Backtrace
Comment 2 Milan Crha 2007-06-14 10:22:59 EDT
I could reproduce this on fresh F7 installation, but not on updated. Please try
to update your F7 installation, maybe it helps.
Comment 3 Bojan Smojver 2007-06-14 17:31:34 EDT
Actually, my box is already running that latest Evo (from updates-testing - see
original report above). Must be something else. There is a whole set of updates
today, so I'll bump everything up first and report back.
Comment 4 Bojan Smojver 2007-06-14 18:01:03 EDT
Sorry, forgot to mention that the rest of the box is also always kept up to
date. But we'll see what happens after today's updates...
Comment 5 Bojan Smojver 2007-06-14 19:08:55 EDT
Yes, even after updates, I can trigger a crash on 3 different systems. Two of
them are i686 machines, one is x86_64.

Maybe it's relevant - all of these machines were upgraded from FC6. Is there
anything you can suggest I remove in ~/.evolution directory that may help? I
found with both Exchange connector (x86_64 machine) and IMAP (the other two), I
needed to remove local mail related files (i.e.
~/.evolution/mail/(imap|exchange)/<account>) in order to stop some mail related
crashes. Maybe you have a clean F7 machine that doesn't have such problems...
Comment 6 Milan Crha 2007-06-15 03:56:19 EDT
You've right, it crashes even after update, I test it on my test installation.
Unfortunately it works when compiled from actual trunk, so I'll investigate more
and let you know.
Comment 7 Milan Crha 2007-06-15 05:21:52 EDT
I found that this is because of wrong filter.glade, it looks like that at least,
because when I put into my /usr/share/evolution/2.10/glade/ this file from
actual svn trunk, then all works fine. I will talk to Matt and let you know then.
Comment 8 Bojan Smojver 2007-07-16 20:37:52 EDT
Still there in 2.10.3-1.fc7
Comment 9 Tim 2007-08-14 03:26:30 EDT
It's still a problem with evolution-2.10.3-2.fc7, and this is a box that was 
done as a fresh installation.  I found the problem while trying to use a date 
as a parameter for a virtual search folder.
Comment 10 Paul Jenner 2007-09-07 14:48:43 EDT
Looks to also be logged upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=473592
Comment 11 Matthew Barnes 2007-09-11 00:47:58 EDT
This seems to be fixed in the latest upstream release.
Comment 12 Bojan Smojver 2007-11-18 17:49:43 EST
Appears to work in F8. Thanks!

PS. Given that the bug has been opened for F7, I won't close it.
Comment 13 Milan Crha 2007-11-21 07:00:51 EST
Thanks for testing, I'm closing it as current release and pointing to Fedora 8
version.
Comment 14 Tim 2008-03-08 06:57:02 EST
(In reply to comment #13)
> Thanks for testing, I'm closing it as current release and pointing to Fedora 8
> version.

Well, I'm still using Fedora 7, Fedora 8 still isn't yet ready for use.  I think
the bug should remain open until it's fixed in Fedora 7, which is still a
current release.  Switching an entire OS release to fix a fault in one
application just isn't a reasonable solution.
Comment 15 Matthew Barnes 2008-03-08 10:20:01 EST
Fedora 8 has been available since September.  Fedora 9 will be available in
about a month.  No more Evolution updates are scheduled for Fedora 7.

Note You need to log in before you can comment on or make changes to this bug.