Bug 24383 - Error when installing on Alpha Server 400 (4/233)
Error when installing on Alpha Server 400 (4/233)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-19 13:31 EST by Rob van Brandenburg
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-26 18:56:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The installer allows you to save the error, this is it. (1.22 KB, patch)
2001-01-19 13:32 EST, Rob van Brandenburg
no flags Details | Diff

  None (edit)
Description Rob van Brandenburg 2001-01-19 13:31:17 EST
Installing RH 7 on Alpha Server 400.
Downloaded RH from FTP site
Bootmethod :
SRM->floppy:aboot->floppy:generic.img->floppy:ramdisk.img->CD

When the installer goes into "Selecting Packages" it blows up.
I think it might have to do with the fact that in the folder
/instimage/usr/lib/python1.5/site-packages
there are 2 files : gtk.py and GTK.py
When burning a CD from a Windows environment, one of the files
gets overwritten..

Saved debug info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
    todo.getCompsList()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 16, in 
readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
    self.readCompsFile(file, self.packages, arch, matchAllLang)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
    comp.addPackage(packages[l])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
    return self.packages[item]
KeyError: MAKEDEV

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 120460e90>
item: MAKEDEV

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Rob van Brandenburg 2001-01-19 13:32:29 EST
Created attachment 7871 [details]
The installer allows you to save the error, this is it.
Comment 2 Michael Fulbright 2001-01-26 11:44:47 EST
Looks like you are getting read errors from your CDs - did you burn these yourself?
Comment 3 Rob van Brandenburg 2001-01-26 12:06:55 EST
Yes I did.

I noticed that in certain directories files exist that are in upper case and 
lower case. Since I am using Windows to burn the CD, this gets screwed up.

IIRC, the file was gtk.py and GTK.py. These are in 
usr/lib/python1.5/site-packages.

Does this mean that I can not use windows to burn a linux CD ?

Thanks,

Rob.
Comment 4 Michael Fulbright 2001-01-26 18:56:38 EST
If you grab the ISO images using a binary transfer method, I think some windows
CD burning software can burn using an ISO image. I don't know the details (I
always use Linux).

Note You need to log in before you can comment on or make changes to this bug.