Bug 243861 - yum-updatesd doesn't apply or download updates automatically.
yum-updatesd doesn't apply or download updates automatically.
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
Depends On:
  Show dependency treegraph
Reported: 2007-06-12 09:16 EDT by Gustavo Maciel Dias Vieira
Modified: 2014-01-21 17:58 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-03 15:57:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gustavo Maciel Dias Vieira 2007-06-12 09:16:43 EDT
Description of problem:

In my setup yum-updatesd doesn't detect, download or applies updates. However,
command line yum, pup and pirut work flawlessly. Moreover, when I turn on the PC
without network connection I get a warning that I'm not receiving updates, so
puplet and the emission of errors in yum-updatesd seems to be working. However,
I have never seen a update notice even after the bunch of updates last week.

I don't believe there is some obvious misconfiguration bug, as I'm sure
yum-updatesd is running, it is properly configured (as long as the documentation
isn't grossly inaccurate) and cli yum works. Things start to get a bit more
interesting when we consider that I have three PCs in this installation and all
of them do not receive updates through yum-updatesd.

I do believe that yum-updatesd works (some people don't :)), so something that
these three machines share must be causing the problems. I have two i386 and a
x86_64 PC, all running F7 in a very standard setup. Only two things related to
yum deviate a bit from the standard and are the same in all three. I use Squid
as a transparent proxy, and I use my own repository configuration file (instead
of the ones provided in /etc/yum.repos.d). I use the proxy to download less, I
use it transparently to configure less things and I use my own yum repos conf to
pin a specific mirror so the proxy will work better and because I have a local
repository. In any case, yum-updatesd *worked* with this setup in FC6 and cli
yum, pup and pirut work now.

That's it. I can post all configuration files. I can collect debug information.
I can bring you coffee. Just ask.

Version-Release number of selected component (if applicable):


How reproducible:

Always. Never worked.
Comment 1 Gustavo Maciel Dias Vieira 2007-06-19 21:09:25 EDT
Ok, I performed some tests, and managed to narrow the cause of the problem with
yum-updatesd. My setup with my repo files and proxy do not play a role in the

Actually, the default behavior: detect updates and notify puplet works
perfectly. The problem is that if I activate any of these configurations below,
yum-updatesd stops working:

# automatically install updates
do_update = no
# automatically download updates
do_download = no
# automatically download deps of updates
do_download_deps = no

Not only it fails to apply or download updates, the notification also fails if
any of the above keys are set to "yes".
Comment 2 Valdis Kletnieks 2007-06-25 23:06:31 EDT
This looks to be a duplicate of bug #239937?

(For what it's worth, I still seeing the problem as well, on a Rawhide box. yum
3.2.1-1.fc8 here)
Comment 3 Jeff 2007-07-23 20:36:32 EDT
I have this problem too. I realize that there are work-arounds out there in the
wild, but it seems to me this is a pretty important core feature for any OS to
have. I was disappointed to see that FC6 had this problem, and I'm wondering why
it's still a problem in F7. 
Comment 4 Seth Vidal 2007-08-03 15:57:17 EDT
Please test yum-updatesd from rawhide and see if it is any better.
Comment 5 Gustavo Maciel Dias Vieira 2007-08-15 16:54:55 EDT
It works (downloads and applies updates).

The only minor annoyance is the problem noted here:

Note You need to log in before you can comment on or make changes to this bug.