Bug 243877 - mysql-python complains about wrong _mysql.so version whereas the version is the same
Summary: mysql-python complains about wrong _mysql.so version whereas the version is t...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Web Application Stack
Classification: Retired
Component: mysql-python   
(Show other bugs)
Version: v2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Greg Nichols
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-12 14:50 UTC by Martin Vecera
Modified: 2013-07-03 03:13 UTC (History)
2 users (show)

Fixed In Version: 1.2.2-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 03:54:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Vecera 2007-06-12 14:50:59 UTC
Description of problem:


Version-Release number of selected component (if applicable):
http://intranet.corp.redhat.com/ic/intranet/RHTSMainPage.html

How reproducible:
100%

Steps to Reproduce:
1. python /usr/lib64/python2.4/site-packages/MySQLdb/__init__.py

  
Actual results:
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/MySQLdb/__init__.py", line 22, in ?
    raise ImportError, "this is MySQLdb version %s, but _mysql is version %r" %\
ImportError: this is MySQLdb version (1, 2, 2, 'final', 0), but _mysql is
version "(1,2,2,'final',0)"


Expected results:
No errors, because the version is the same.

Additional info:
I found this bug when trying to do Python-MySQL connection tests. It appears
immediately when you try to import MySQLdb package.

Comment 1 Tom Lane 2007-06-12 19:39:45 UTC
Doh, silly quoting problem.  Try 1.2.2-2

Comment 2 Fedora Update System 2007-06-13 21:01:55 UTC
MySQL-python-1.2.2-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 3 Fedora Update System 2007-06-27 03:54:36 UTC
MySQL-python-1.2.2-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Julian Yap 2007-07-01 03:24:20 UTC
I expect this to break a lot of applications which do MySQL-python version
checking.  Django is broken because of this change.

On my Fedora 7 system.

$ python
Python 2.5 (r25:51908, Apr 10 2007, 10:29:13)
[GCC 4.1.2 20070403 (Red Hat 4.1.2-8)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import MySQLdb as Database
>>> version = Database.version_info
>>> print version
(1,2,2,'final',0)
>>> if (version < (1,2,1) or (version[:3] == (1, 2, 1) and
...         (len(version) < 5 or version[3] != 'final' or version[4] < 2))):
...     raise ImportError, "MySQLdb-1.2.1p2 or newer is required; you have %s" %
Database.__version__
...
Traceback (most recent call last):
  File "<stdin>", line 3, in <module>
ImportError: MySQLdb-1.2.1p2 or newer is required; you have 1.2.2



Note You need to log in before you can comment on or make changes to this bug.