Bug 243968 - running powertop for a while totally freezes system
running powertop for a while totally freezes system
Product: Fedora
Classification: Fedora
Component: powertop (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-06-13 00:57 EDT by Michal Žejdl
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.8-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-16 05:22:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Žejdl 2007-06-13 00:57:43 EDT
Description of problem:
System freezes after minutes or tens of minutes when powertop is running. It
stops answering completely - screen, keyboard, no ICMP response... This system
runs continually without problem for a week (from fresh F7 install) and with >
100 days uptime with FC6. Yesterday I started to play with powertop and got
three times freeze after while.

Version-Release number of selected component (if applicable):
powertop 1.6 (compiled from source)

How reproducible:
three successful trials

Steps to Reproduce:
1. run powertop and wait for freeze
Actual results:

Expected results:
powertop running for hours without problem

Additional info:
powertop was in xterm window and IceWM session
P4@2.8GHz, mobo ASUS P4P800-VM, 1GB RAM, Radeon 9200 (radeon driver)...
Comment 1 Christopher Brown 2007-09-16 17:47:03 EDT

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.


I am CC'ing myself to this bug and have re-assigned it to the powertop
maintainer who may wish to add their comments. You may also like to update to
the latest version of powertop.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel? If so, you may wish to try
the following to assist in its debugging:

# For boot related issues we need as much info as possible, so removing quiet
from boot flags is a good start.

# Slowing down the speed of text output with boot_delay=1000 (the number may
need to be tweaked higher/lower to suit) may allow the user to take a digital
camera photo of the last thing on screen.

# Booting with vga=791 (or even just vga=1 if the video card won't support 791)
will put the framebuffer into high resolution mode to get more lines of text on
screen, allowing more context for bug analysis.

# initcall_debug will allow to see the last thing the kernel tried to initialise
before it hung.

# There are numerous switches that change which at times have proven to be
useful to diagnose failures by disabling various features.

* acpi=off is a big hammer, and if that works, narrowing down by trying
pci=noacpi instead may yield clues
* nolapic and noapic are sometimes useful
* Given it's new and still seeing quite a few changes, nohz=off may be worth
testing. (Though this is F7 and above only) 

# If you get no output at all from the kernel, sometimes booting with
earlyprintk=vga can sometimes yield something of interest.

# If the kernel locks up with a 'soft lockup' report, booting with nosoftlockup
will disable this check allowing booting to continue.

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Comment 2 Michal Žejdl 2007-11-16 05:22:52 EST
  sorry for answering too late, but I haven't got your post by mail.

I moved to Fedora 8 and problem is solved for me now - powertop runs for hours
without problem.

Thanks for your care.


Note You need to log in before you can comment on or make changes to this bug.