Bug 243976 - mmap'd files with large inode numbers confuse lsof
mmap'd files with large inode numbers confuse lsof
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lsof (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Peter Schiffer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 02:07 EDT by Andrew C Aitchison
Modified: 2012-01-12 11:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-12 11:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew C Aitchison 2007-06-13 02:07:14 EDT
Description of problem:
large inode numbers confuse code which detects replaced files

Version-Release number of selected component (if applicable):
lsof-4.78-3.x86_64

How reproducible:
consistent

Steps to Reproduce:
1. mmap a file with a numerically large inode - say 2^31 < inum < 2^32.
/proc is a good place to find these
2. run lsof on the mmap'ing process
  
Actual results:
lsof reports the mapped file with "NODE" as a 64bit large/negative number, eg
memmap  23056 root  mem    REG    0,3         18446744073441117670
/proc/xen/privcmd (path inode=4026533350)

# ls -li /proc/xen/privcmd 
4026533350 -r-------- 1 root root 0 Jun  7 06:22 /proc/xen/privcmd

Note that the last 32 bits of 18446744073441117670 match 4026533350:
# echo 16o 18446744073441117670 p 4026533350  p | dc 
FFFFFFFFF00005E6
F00005E6
#

Expected results:
NODE to be 4026533350 - same as reported by ls -li and by the "path inode=" test

Additional info:
Comment 1 Karel Zak 2007-06-13 04:18:31 EDT
Good catch! Thanks.
Comment 2 Karel Zak 2007-10-02 08:40:17 EDT
... because it uses:

    inode = (INODETYPE)atoi(fp[5]);

for /proc/#/maps  ;-)
Comment 3 RHEL Product and Program Management 2007-12-03 15:43:23 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 4 RHEL Product and Program Management 2009-11-06 13:45:58 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 RHEL Product and Program Management 2010-08-09 14:21:40 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-11 15:27:05 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-01-11 18:02:32 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 9 RHEL Product and Program Management 2011-05-31 09:22:37 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-09-22 20:09:06 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 Peter Schiffer 2012-01-12 11:47:36 EST
I am closing this as WONTFIX because lsof probably won't be updated again in RHEL-5 and this issue is fixed in RHEL-6 and upstream version of lsof. Thank you for your report.

Note You need to log in before you can comment on or make changes to this bug.