Bug 243979 - PV-on-HVM interrupts not delivered promptly in APIC mode
Summary: PV-on-HVM interrupts not delivered promptly in APIC mode
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Rik van Riel
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-13 06:42 UTC by Herbert Xu
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:53:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Herbert Xu 2007-06-13 06:42:16 UTC
The delivery of PV-on-HVM interrupts are broken in APIC mode.  When the guest is
woken up it fails to inject an interrupt immediately into it.  Therefore the
interrupt is only delivered when the next interrupt (usually a timer interrupt)
is injected.

Booting with noapic cures the problem.  The problem is also fixed in Xen 3.1.

Comment 1 Rik van Riel 2007-06-13 13:38:56 UTC
We should be fine for RHEL 5.1 then, since we are upgrading the hypervisor to 
version 3.1.

Comment 2 Rik van Riel 2007-06-29 18:28:09 UTC
The Xen 3.1.0 hypervisor got merged in 2.6.18-29.el5.

Comment 3 Red Hat Bugzilla 2007-07-25 00:51:50 UTC
change QA contact

Comment 6 errata-xmlrpc 2007-11-07 19:53:06 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.