Bug 244027 - brasero fails to blank a cdrw / drive is busy
brasero fails to blank a cdrw / drive is busy
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: brasero (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 09:25 EDT by Sebastian Vahl
Modified: 2008-01-10 20:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 20:22:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2007-06-13 09:25:44 EDT
Description of problem:
If you have a cdrw that contains data and you want to erase or overwrite the
cdrw, brasero fails with this message:

Error Blanking:
the drive seems to be busy.


Version-Release number of selected component (if applicable):
brasero-0.5.2-1.fc7

How reproducible:
ever

Steps to Reproduce:
1. insert a cdrw with data on it
2. wait until gnome-volume-manager mounts the cdrw
3. start brasero
4. try to erase the cdrw
  
Actual results:
brasero fails to umount the cdrw.

Expected results:
brasero should umount the cdrw and clean it.

Additional info:

1. Output of "brasero --debug":

** (brasero:8967): WARNING **: Couldn't unmount volume in drive: /dev/scd1

** (brasero:8967): WARNING **: Couldn't unmount volume in drive: /dev/scd1
(brasero:8967): BraseroBurn-DEBUG: recorder (BraseroCDRecord) set_drive
(brasero:8967): BraseroBurn-DEBUG: recorder (BraseroCDRecord) set_flags

gnome-mount 0.6
Ejected /dev/scd1

2. A gnome-umount -d /dev/scd1 works fine. After doing that also brasero blanks
the cdrw.
Comment 1 Martin Sourada 2007-07-20 08:16:24 EDT
This issue should be fixed in 0.6.0 version in upstream. Consider upgrade? (note
that it also needs new libburn and libisofs, which are not in repos either)

http://ftp.gnome.org/pub/gnome/sources/brasero/0.6/brasero-0.6.0.tar.bz2
Comment 2 Denis Leroy 2008-01-10 20:22:26 EST
Closing, since 0.6.1 is now in F-7. Please reopen if problem happens again.

Note You need to log in before you can comment on or make changes to this bug.