Bug 244036 - missing link from readom to readcd
missing link from readom to readcd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 09:54 EDT by Sebastian Vahl
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1.6-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 23:54:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2007-06-13 09:54:04 EDT
Description of problem:
cdrtools shipped readcd. This program is used eg by graveman to copy cds. But
graveman could not find readcd because this one is missing and readom is not
linked to readcd (as cdrecord links to cdrecord).


Version-Release number of selected component (if applicable):
wodim-1.1.2-4.fc7

How reproducible:
ever

Steps to Reproduce:
1. yum install wodim graveman
2. start graveman
3. see "File -> Preferences -> External programs". 

Actual results:
graveman could not copy cds because it is missing readcd.

Expected results:
readcd should be a symlink to readom so that graveman could find readcd.

Additional info:
1. A simple "ln -s /usr/bin/readom /usr/bin/readcd" would do the job.

2. I filed this bug against cdrkit because wodim has no single entry in bugzilla.
Comment 1 Harald Hoyer 2007-06-21 06:34:29 EDT
cdrkit-1.1.6 will hit F-7-testing..
Comment 2 Fedora Update System 2007-06-21 16:02:25 EDT
cdrkit-1.1.6-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2007-06-26 23:53:59 EDT
cdrkit-1.1.6-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Luis Felipe Marzagao 2007-10-06 22:06:55 EDT
The problem still persists in wodim 1.1.6-5:


[root@localhost ~]# yum list | grep -i wodim
wodim.i386 1.1.6-5.fc7 installed

[root@localhost ~]# rpm -ql wodim
/usr/bin/cdrecord
/usr/bin/devdump
/usr/bin/dvdrecord
/usr/bin/readom
/usr/bin/wodim
/usr/sbin/netscsid
/usr/share/doc/wodim-1.1.6
/usr/share/doc/wodim-1.1.6/COPYING
/usr/share/doc/wodim-1.1.6/Changelog
/usr/share/doc/wodim-1.1.6/FAQ
/usr/share/doc/wodim-1.1.6/FORK
/usr/share/doc/wodim-1.1.6/READMEs
/usr/share/doc/wodim-1.1.6/READMEs/README.ATAPI
/usr/share/doc/wodim-1.1.6/READMEs/README.ATAPI.setup
/usr/share/doc/wodim-1.1.6/READMEs/README.audio
/usr/share/doc/wodim-1.1.6/READMEs/README.cdplus
/usr/share/doc/wodim-1.1.6/READMEs/README.cdtext
/usr/share/doc/wodim-1.1.6/READMEs/README.copy
/usr/share/doc/wodim-1.1.6/READMEs/README.multi
/usr/share/doc/wodim-1.1.6/READMEs/README.netscsid
/usr/share/doc/wodim-1.1.6/READMEs/README.sony
/usr/share/doc/wodim-1.1.6/READMEs/README.suidroot
/usr/share/doc/wodim-1.1.6/READMEs/README.verify
/usr/share/doc/wodim-1.1.6/START
/usr/share/doc/wodim-1.1.6/wodim
/usr/share/doc/wodim-1.1.6/wodim/README.DiskT@2
/usr/share/doc/wodim-1.1.6/wodim/README.WORM
/usr/share/doc/wodim-1.1.6/wodim/README.cdrw
/usr/share/doc/wodim-1.1.6/wodim/README.clone
/usr/share/doc/wodim-1.1.6/wodim/README.raw
/usr/share/man/man1/devdump.1.gz
/usr/share/man/man1/readom.1.gz
/usr/share/man/man1/wodim.1.gz
Comment 5 Harald Hoyer 2007-10-08 03:23:48 EDT
$ ll /usr/bin/readcd
lrwxrwxrwx 1 root root 33 2007-09-27 12:50 /usr/bin/readcd ->
/etc/alternatives/cdrecord-readcd
$ ll /etc/alternatives/cdrecord-readcd
lrwxrwxrwx 1 root root 15 2007-09-27 12:50 /etc/alternatives/cdrecord-readcd ->
/usr/bin/readom
Comment 6 Luis Felipe Marzagao 2007-10-08 16:08:16 EDT
[root@localhost ~]# yum list | grep -i wodim
wodim.i386                               1.1.6-5.fc7            installed 

[root@localhost ~]# ll /usr/bin/readcd
ls: impossível acessar /usr/bin/readcd: Arquivo ou diretório não encontrado

[root@localhost ~]# ll /etc/alternatives/cdrecord-readcd
lrwxrwxrwx 1 root root 15 2007-10-05 10:58 /etc/alternatives/cdrecord-readcd ->
/usr/bin/readom

So I guess de solution is manually create the /usr/bin/readcd link. Because I've
never erased it (that´s for sure!!!)



Comment 7 Forrest Cahoon 2007-10-08 23:34:53 EDT
Same here with fc7 on x86_64:

[root@celeste ~]# yum list | grep -i wodim
wodim.x86_64                             1.1.6-5.fc7            installed       

The symlink created by alternatives is getting automatically deleted by some
process or another.  The data in /var/lib/alternatives/cdrecord looks right, though.

Here's my workaround, making use of the alternatives program (although I suppose
it effectively does the same thing as manually creating the missing symlink):

[root@celeste ~]# /usr/sbin/alternatives --config cdrecord

There is 1 program that provides 'cdrecord'.

  Selection    Command
-----------------------------------------------
*+ 1           /usr/bin/wodim

Enter to keep the current selection[+], or type selection number: 1
[root@celeste ~]# /usr/sbin/alternatives --auto cdrecord

After that, everything should be fine.


Comment 8 Harald Hoyer 2007-10-09 05:41:04 EDT
If you can access this, please try, if this fixes your issues:
http://koji.fedoraproject.org/koji/buildinfo?buildID=19709

Note You need to log in before you can comment on or make changes to this bug.