Bug 244079 - kernel: hub 3-0:1.0: port 3 disabled by hub (EMI?), re-enabling...
Summary: kernel: hub 3-0:1.0: port 3 disabled by hub (EMI?), re-enabling...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: i386 Linux
low
high
Target Milestone: ---
: ---
Assignee: John Feeney
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-13 17:36 UTC by Thomas
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: 2.6.18-8.1.8.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 13:30:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas 2007-06-13 17:36:26 UTC
Under kernel 2.6.18-8.1.4 PAE USB errors plague Dell PowerEdge SC1435 systems:

Jun 13 12:56:12 www1 kernel: hub 3-3:1.0: USB hub found
Jun 13 12:56:12 www1 kernel: hub 3-3:1.0: 2 ports detected
Jun 13 12:56:12 www1 kernel: hub 3-0:1.0: port 3 disabled by hub (EMI?), re-enabling...
Jun 13 12:56:12 www1 kernel: usb 3-3: USB disconnect, address 68
Jun 13 12:56:13 www1 kernel: usb 3-3: new high speed USB device using ehci_hcd and address 69
Jun 13 12:56:13 www1 kernel: usb 3-3: configuration #1 chosen from 1 choice

Errors continue in an infinite loop.

This problem is NOT present in outdated 2.6.18-8 kernel.

Unloading ehci_hcd also resolves errors, but does not satisfy udev.

Comment 1 Jarod Wilson 2007-09-02 03:10:24 UTC
Thomas, can you try out the latest rhel5.1 beta kernel to confirm whether or not this issue still persists?

http://people.redhat.com/dzickus/el5/


Comment 2 Thomas 2007-09-10 12:47:12 UTC
I can't try a beta kernel on one of our production systems, I can tell you that
our previous deployments of the same SC1435 build using the latest RHEL 5 (1.8)
kernel did not report these errors for us.

Comment 3 Jarod Wilson 2007-09-10 13:30:56 UTC
Ah, excellent. If the problem is fixed in 2.6.18-8.1.8.el5, then it should also
be fixed in the latest RHEL5.1 beta kernels.


Note You need to log in before you can comment on or make changes to this bug.