Bug 244085 - ADSL connection timeout problems with F7
ADSL connection timeout problems with F7
Status: CLOSED DUPLICATE of bug 248821
Product: Fedora
Classification: Fedora
Component: rp-pppoe (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 14:16 EDT by Klaubert Herr
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 19:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaubert Herr 2007-06-13 14:16:01 EDT
+++ This bug was initially created as a clone of Bug #242634 +++

Description of problem:

Activating ADSL no longer appears to work in Fedora 7 after using
the same hardware in FC 3 to FC 6.  There are continual timeouts and
the resulting connection is subsequently terminated.

Example errors from /var/log/messages:

pppd[3395]: pppd 2.4.4 started by root, uid 0
pppd[3395]: Using interface ppp0
pppd[3395]: Connect: ppp0 <--> /dev/pts/3
pppd[3395]: LCP: timeout sending Config-Requests
pppd[3395]: LCP: Connection terminated
pppd[3395]: LCP: Modem hangup
pppd[3395]: LCP: Timeout waiting for PADO packets
...etc

ADSL setup was done using /usr/sbin/pppoe-setup providing the same
data as in earlier versions of Fedora.

Full details of 2 people having the same problem (with debugging output
in 2nd report) are available at:

    http://forums.fedoraforum.org/showthread.php?p=803017

Version-Release number of selected component (if applicable):
rp-pppoe-3.8-1.fc7
ppp-2.4.4-2

To reproduce:

run /usr/sbin/adsl-start are configuring ADSL connection
with /usr/sbin/pppoe-setup

-- Additional comment from jamie@bigpond.net.au on 2007-06-05 10:42 EST --
For some reason, this problem has now been solved by just re-installing PPP
from the Fedora 7 install DVD.  I.e.:

rpm -i --replacepkgs [path to ppp-2.4.4-2 RPM on Fedora 7 installation DVD]

Once that was done, adsl worked (i.e. no connection timeouts).

This solution was quite by accident.  I originally slotted in the FC6 binaries of
pppoe and pppd in the hope they'd work, but accidentally deleted the original
F7 version of pppd requiring me to re-install it from DVD.

So I guess this can be closed...

UPDATE: I have the same problema described above (Bug #242634 (cloned here)),
but the solution sugested in original bug report don't work.
A work-around was possible booting the _non_ Xen kernel, in my instalation the
Xen kernel was default.
Probably some investigation still needed...
Comment 1 Roman Kisilenko 2007-07-06 06:37:39 EDT
I have to run a fedora - based router inside a paravirtualized domU under xen,
so I can not just switch to a non-xen kernel like many others do and have to
temporary switch another guest os. Below is what I was able to figure out
regarding this problem.

1) problem happens if xen kernel is used (e.g. 2.6.20-2925.11.fc7xen)
2) problem does not depends on ethernet configuration. I've tried to run pppoe
client on dedicated ethernet interface in dom0 and domU, on bridged interface.
No luck.
3) If I look at the network exchange with a sniffer program, I see that PADI
requests are sent successfully and pppoe server responds to the requests
correctly. However pppd feels like it never receives any response.
4) If I run the tcpdump under the xen kernel I never see the pppoe exchange and
when I do it under the non-xen kernel I see it.

Hope above items can be useful.
Comment 2 dfobrien 2007-07-08 21:29:03 EDT
I'm having the same problem. I'm running the xen kernel in dom0, and I haven't yet
been able to get an adsl connection, after configuring by running "pppoe-setup"
and entering the same settings as I used in fedora core 6 for "adsl-setup". I
haven't tried booting the non-xen kernel and repeating the attempt (for now I've
gone back to using fedora core 6).
Comment 3 styno 2007-07-16 02:50:22 EDT
Same issue here.  At the moment there seems to be no way to have both xen & adsl
up and running.  

Booting with xen enabled kernel (2.6.20-2925.11.fc7xen -64Bit-) doesn't allow
ppp to connect (timeout).
Booting with non-xen kernel (2.6.21-1.3228.fc7 -64Bit-) with the same ppp
settings confirmed to work.  
Comment 4 Arik Raffael Funke 2007-07-20 17:37:31 EDT
I am not sure whether this is obvious, but: the problem is not restricted to 
the dom0 but also arises when a domU runs on Fedora 7 and tries to connect to a 
adsl modem via a dedicated network card.

Centos 5.0 and Fedora Core 6 both do not experience this problem.
Comment 5 styno 2007-08-01 19:43:09 EDT
Tested with the new 'kernel-xen-2.6.20-2925.13.fc7'...  no luck
Comment 6 Herbert Xu 2007-08-07 19:38:54 EDT

*** This bug has been marked as a duplicate of 248821 ***

Note You need to log in before you can comment on or make changes to this bug.