Bug 244090 - mysql-administrator crashes with seg fault
mysql-administrator crashes with seg fault
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mysql-gui-tools (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
: 245242 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 14:47 EDT by Sebastian Kloska
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0r12-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 19:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Kloska 2007-06-13 14:47:23 EDT
Description of problem:

mysql-administrator crashes with seg fault when creating a new scheme. 

Version-Release number of selected component (if applicable):

5.0r11-3.fc7

How reproducible:

Always

Steps to Reproduce:
1. Start up and connect
2. Select "New scheme" from "database catalog"
3. Name the scheme
4. Crash
  
Actual results:

/usr/bin/mysql-administrator: line 105:  3189 Segmentation fault      $PRG-bin $args

Expected results:

Well... something different ;)

Additional info:

Also reproducable on x86_64

When I compile the mysql-gui-tools from the 5.0r12 tar ball from mysql.com

with

./configure  --with-gtkhtml=libgtkhtml-3.14

it gives me a nice working admin tool

When running mysql-administrator-bin under gdb from within the
mysql-administrator script I get the following stack trace

#0  0x08193f84 in ?? ()
#1  0x08066c3f in ?? ()
#2  0x081560b4 in ?? ()
#3  0x0806777a in ?? ()
#4  0x08067884 in ?? ()
#5  0x080f0ff3 in ?? ()
#6  0x009a854a in Glib::SignalProxyNormal::slot0_void_callback () from
/usr/lib/libglibmm-2.4.so.1
#7  0x003aa0f9 in g_cclosure_marshal_VOID__VOID () from /lib/libgobject-2.0.so.0
#8  0x0039cd9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#9  0x003ad721 in ?? () from /lib/libgobject-2.0.so.0
#10 0x003ae957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#11 0x003aeb19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#12 0x02f89844 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x02e7d418 in gtk_menu_shell_activate_item () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x02e7e9e2 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x02e76655 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x0514376b in Gtk::Widget_Class::button_release_event_callback () from
/usr/lib/libgtkmm-2.4.so.1
#17 0x02e70770 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#18 0x0039b589 in ?? () from /lib/libgobject-2.0.so.0
#19 0x0039cd9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#20 0x003ada83 in ?? () from /lib/libgobject-2.0.so.0
#21 0x003ae71f in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#22 0x003aeb19 in g_signal_emit () from /lib/libgobject-2.0.so.0
#23 0x02f85498 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#24 0x02e69b33 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x02e6ad37 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x0060d40a in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#27 0x002e4622 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#28 0x002e75ff in ?? () from /lib/libglib-2.0.so.0
#29 0x002e79a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#30 0x02e6b1b4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x050c8fa7 in Gtk::Main::run_impl () from /usr/lib/libgtkmm-2.4.so.1
#32 0x050c8d92 in Gtk::Main::run () from /usr/lib/libgtkmm-2.4.so.1
#33 0x08096483 in ?? ()
#34 0x00dbaf70 in __libc_start_main () from /lib/libc.so.6
#35 0x08063f01 in non-virtual thunk to Gtk::DrawingArea::~DrawingArea() ()

Bye
Comment 1 Dennis Gilmore 2007-06-17 16:18:10 EDT
updated build going into updates-testing  please test and report back.

moving to correct component mysql-administrator is no longer standalone.
Comment 2 Fedora Update System 2007-06-18 12:37:10 EDT
mysql-gui-tools-5.0r12-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Sebastian Kloska 2007-06-18 15:48:54 EDT
(In reply to comment #2)
> mysql-gui-tools-5.0r12-2.fc7 has been pushed to the Fedora 7 testing
repository.  If problems still persist, please make note of it in this bug report.

Seems to work just fine both for i386 & x86_64.. thank you !!
Comment 4 Dennis Gilmore 2007-06-21 22:54:45 EDT
*** Bug 245242 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2007-06-25 19:23:26 EDT
mysql-gui-tools-5.0r12-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.