Bug 244091 - koffice: Most programs die immediately on start-up
Summary: koffice: Most programs die immediately on start-up
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: koffice   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-13 18:49 UTC by Mary Ellen Foster
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 10:26:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mary Ellen Foster 2007-06-13 18:49:39 UTC
Description of problem:
Most of the koffice components in the new updates-testing package exit 
immediately when they're run. The only one that starts up properly seems to 
be "kugar". The versions from the base Fedora install (1.6.2-3.fc7) work fine; 
this is definitely a regression in 1.6.3-1.

Version-Release number of selected component (if applicable):
koffice-suite-1.6.3-1.fc7

How reproducible:
Every time

Steps to Reproduce:
1. Run "kspread", "kpresenter", "kword", "krita", "karbon", ...
  
Actual results:
Command prompt returns immediately, program does not start (no error message, 
no process running in "ps", nothing).

Expected results:
Requested program should start

Comment 1 Rex Dieter 2007-06-13 19:00:57 UTC
Odd, WORKSFORME.  ???

Does:
$ rpm -Va koffice-*
report anything?

Comment 2 Mary Ellen Foster 2007-06-13 22:18:59 UTC
I just tried on another Fedora 7 machine and the same thing happened. The 
rpm -V command didn't return anything

Comment 3 Gianluca Varisco 2007-06-13 22:26:43 UTC
I can confirm what Mary Ellen Foster reported; kugar is the only app that starts
correctly.

Regarding " rpm -Va koffice-* ", it didn't return anything. If needed, I can
provide only the output of 'strace $APP'.

Comment 4 Rex Dieter 2007-06-15 12:27:43 UTC
What arch you folks running?  i386, x86_64 (or ppc)?

Comment 5 Gianluca Varisco 2007-06-15 12:33:38 UTC
Rex, I'm running i386.

Comment 6 Mary Ellen Foster 2007-06-15 12:42:22 UTC
i386 as well on both machines I tested this on.

Comment 7 Rex Dieter 2007-06-15 16:00:09 UTC
confirmed, looks like our koffice build was done against kdelibs-3.5.7, and
exibits this problem on machines with kde < 3.5.7.

I'll withdraw the update, and rebuild with Requires: kdelibs >= 3.5.7.

Comment 8 Gianluca Varisco 2007-06-15 16:04:02 UTC
I tried too and with kdelibs 3.5.7 it works.

Comment 9 Mary Ellen Foster 2007-06-15 16:05:42 UTC
Where are you getting 3.5.7 from? Rawhide? That doesn't seem to be in 
updates-testing yet ...

Comment 10 Gianluca Varisco 2007-06-15 16:08:32 UTC
Yes, at the moment it's only available in Koji (
http://koji.fedoraproject.org/koji/buildinfo?buildID=8241 ).

Comment 11 Rex Dieter 2007-06-15 16:18:20 UTC
building now...

* Fri Jun 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org>
1.6.2-2
- Require version of kdelibs used to build against (#244091)
- -suite: use versioned Requires


Comment 12 Rex Dieter 2007-06-19 20:03:46 UTC
koffice-1.6.3-3.fc7 update request queue'd.

Comment 13 Fedora Update System 2007-06-19 21:37:15 UTC
koffice-1.6.3-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Gianluca Varisco 2007-06-21 08:48:24 UTC
Now it works perfectly. Thank you, Rex.

Comment 15 Fedora Update System 2007-06-25 23:20:52 UTC
koffice-1.6.3-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2007-07-02 16:09:33 UTC
koffice-1.6.3-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.