Bug 244107 - /usr/bin/system-config-selinux crashes
/usr/bin/system-config-selinux crashes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 16:33 EDT by David
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 09:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David 2007-06-13 16:33:20 EDT
Description of problem:

/usr/bin/system-config-selinux crashes

Version-Release number of selected component (if applicable):
policycoreutils-2.0.20-1.fc8.i386

How reproducible:
always

Steps to Reproduce:
1.mouse click on GNOME Menu launcher - SELinux Management
2.CLI (as root) /usr/bin/system-config-selinux <enter>
3.
  
Actual results:
It crashes

Expected results:
Start of GUI to configure SELinux

Additional info:

***MEMORY-WARNING***: system-config-selinux.py[3284]: GSlice: g_thread_init()
must be called before all other GLib functions; memory corruption due to late
invocation of g_thread_init() has been detected; this program is likely to
crash, leak or unexpectedly abort soon...
/usr/share/system-config-selinux/system-config-selinux.py:72: Warning:
IA__g_object_get_valist: object class `GnomeProgram' has no property named
`default-icon'
  xml = gtk.glade.XML
("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 171, in
<module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 90, in
__init__
    self.add_page(modulesPage.modulesPage(xml)) # modules
  File "/usr/share/system-config-selinux/modulesPage.py", line 51, in __init__
    self.module_filter.connect("focus_out_event", self.filter_changed)
AttributeError: 'NoneType' object has no attribute 'connect'
Comment 1 Daniel Walsh 2007-06-14 08:09:50 EDT
Fixed in policycoreutils-2.0.21-2.fc8.i386
Comment 2 David 2007-06-14 13:29:12 EDT
(In reply to comment #1)
> Fixed in policycoreutils-2.0.21-2.fc8.i386

The GUI doe indeed run both from the launcher and from the CLI. However this is
still reported when run from the CLI

***MEMORY-WARNING***: system-config-selinux.py[2881]: GSlice: g_thread_init()
must be called before all other GLib functions; memory corruption due to late
invocation of g_thread_init() has been detected; this program is likely to
crash, leak or unexpectedly abort soon...
/usr/share/system-config-selinux/system-config-selinux.py:72: Warning:
IA__g_object_get_valist: object class `GnomeProgram' has no property named
`default-icon'
  xml = gtk.glade.XML
("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)

Is this significant?

Comment 3 Daniel Walsh 2007-06-14 13:37:21 EDT
I don't know.  :^(

But I think these are problems with gtk/gnome/python not with
system-config-selinux.  
Comment 4 David 2007-06-15 05:27:58 EDT
(In reply to comment #3)
> I don't know.  :^(
> 
> But I think these are problems with gtk/gnome/python not with
> system-config-selinux.

The work that you performed fixed this. You should close this bug.  


Note You need to log in before you can comment on or make changes to this bug.