Bug 244114 - Autofs v5 removes directories that it did not create
Summary: Autofs v5 removes directories that it did not create
Status: CLOSED DUPLICATE of bug 223480
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Ian Kent
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-13 21:16 UTC by Jeff Moyer
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 14:08:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Moyer 2007-06-13 21:16:53 UTC
Description of problem:
Autofs should not remove directories if they existed on the system before
automount was started.

This is a regression from v4.

Version-Release number of selected component (if applicable):
autofs 5.0.1-0.rc2.42

How reproducible:
100%

Steps to Reproduce:

auto.master:
/test /etc/auto.test

mkdir /test/

service autofs start
service autofs stop

ls /test/
No such file or directory

Comment 1 Jeff Moyer 2007-06-13 21:17:23 UTC
See also bz #134399.  I found this when writing regression tests.

Comment 2 Ian Kent 2007-06-14 14:06:43 UTC
(In reply to comment #1)
> See also bz #134399.  I found this when writing regression tests.

Please test with revision 0.rc2.44 or later and see
bz 223480 that should address this problem.

Ian


Comment 3 Jeff Moyer 2007-06-14 14:08:03 UTC
Sorry for the duplicate, Ian!

*** This bug has been marked as a duplicate of 223480 ***


Note You need to log in before you can comment on or make changes to this bug.