Bug 244124 - Anaconda fails to upgrade FC6 to F7 with a python exception (with workaround)
Anaconda fails to upgrade FC6 to F7 with a python exception (with workaround)
Status: CLOSED DUPLICATE of bug 241991
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 19:05 EDT by Oron Peled
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 09:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oron Peled 2007-06-13 19:05:25 EDT
Description of problem:
During an upgrade from FC6 to F7 after selecting the boot loader
options, there was a python exception in:
  /usr/lib/anaconda/textw/upgrade_bootloader_text.py line 152

After checking this I found the cause: an empty line in my /etc/modprobe.conf.
Removing empty lines before update solved the problem.

How reproducible:
Put empty line(s) into /etc/modprobe.conf before upgrade.

Additional info:
The code in this line is the culprit:
      if l.strip()[0] == "#":
It assumes a non-empty line.
Comment 1 Chris Lumens 2007-06-14 09:39:35 EDT

*** This bug has been marked as a duplicate of 241991 ***

Note You need to log in before you can comment on or make changes to this bug.