Bug 244141 - SELinux is preventing /usr/bin/updatedb (locate_t) "write" to socket (nscd_var_run_t).
SELinux is preventing /usr/bin/updatedb (locate_t) "write" to socket (nscd_va...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 00:02 EDT by Chris Edsall
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 09:18:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sealert output (2.26 KB, text/plain)
2007-06-14 00:02 EDT, Chris Edsall
no flags Details

  None (edit)
Description Chris Edsall 2007-06-14 00:02:16 EDT
Description of problem:

With name service caching daemon (nscd) enabled, locate generates an selinux
violation that results in 

Version-Release number of selected component (if applicable):

[root@smog ~]# cat /etc/issue ; rpm -q selinux-policy-targeted  mlocate
Fedora release 7 (Moonshine)
Kernel \r on an \m

selinux-policy-targeted-2.6.4-12.fc7
mlocate-0.16-1

How reproducible:


Steps to Reproduce:
1. enable nscd at installation
2. wait for updatedb to run
  
Actual results:

Error message 
SELinux is preventing /usr/bin/updatedb (locate_t) "write" to socket
(nscd_var_run_t).

Expected results:

No error

Additional info:

sealert output attached
Comment 1 Chris Edsall 2007-06-14 00:02:16 EDT
Created attachment 156951 [details]
sealert output
Comment 2 Daniel Walsh 2007-06-14 09:18:54 EDT
Are you running in permissive mode.  This avc should be blocked in enforcing mode.

If the avc message does not show up in enforcing mode it is not a bug.

Note You need to log in before you can comment on or make changes to this bug.