Bug 244191 - Hardware Catelog test result differs from the actual result shown in terminal during testing
Hardware Catelog test result differs from the actual result shown in terminal...
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 09:42 EDT by Satyabrata Maitra
Modified: 2008-07-16 18:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-15 22:02:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
i386-server (3.48 MB, application/x-rpm)
2007-06-25 08:12 EDT, Satyabrata Maitra
no flags Details
ia64-server (8.72 MB, application/x-rpm)
2007-06-25 08:13 EDT, Satyabrata Maitra
no flags Details
ppc-server (2.48 MB, application/x-rpm)
2007-06-25 08:16 EDT, Satyabrata Maitra
no flags Details
x86_64-server (9.57 MB, application/x-rpm)
2007-06-25 08:18 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2007-06-14 09:42:26 EDT
Description of problem:
Hardware Catelog test result differs from the actual result shown in terminal
during testing, for i386-server, ia-64, ppc, x86_64. When tested it with command
: hts certify -- test XXXX, its given a result, which sometimes not matching
with the result which is giving after I upload the rpm ( build from command hts
submit).

Version-Release number of selected component (if applicable):
hts-5.0-48

How reproducible:
random

Steps to Reproduce:
1. Test for HTS with specific arch at a time
2. follow the test result shown in the terminal after test finish.
3. get the rpm by hts submit once all test done.
4. login to https://hardware.redhat.com
5. select create from the left hand navigation
6. fill out form with example data
7. select "have package"
8. associate one of the result packages
9. select upload package
10. catalog should show a verify screen; submit this
11. Observe the tabular sheet for the test result against various hardware.
  
Actual results:
both terminal test result and catelog test result is not the same showing

Expected results:
both terminal test result and catelog test result should be same.

Additional info:
Comment 1 Greg Nichols 2007-06-19 11:47:37 EDT
Please attach the results rpm and/or links to the Handware Catalog pages where
these results were submitted.

Thanks!
Comment 2 Satyabrata Maitra 2007-06-25 04:47:18 EDT
Hi Greg

May I know how to find the certification rpm that I submitted in
hardware.redhat.com? Do I need approval first it gets published? Please inform.
Then I may give you the URL so that you can see the submission i commited!
Comment 3 Satyabrata Maitra 2007-06-25 08:11:01 EDT
And the results .rpm files for each archs tested, I am attaching with this bug now.
Comment 4 Satyabrata Maitra 2007-06-25 08:12:22 EDT
Created attachment 157738 [details]
i386-server
Comment 5 Satyabrata Maitra 2007-06-25 08:13:39 EDT
Created attachment 157740 [details]
ia64-server
Comment 6 Satyabrata Maitra 2007-06-25 08:16:59 EDT
Created attachment 157744 [details]
ppc-server
Comment 7 Satyabrata Maitra 2007-06-25 08:18:17 EDT
Created attachment 157745 [details]
x86_64-server
Comment 8 YangKun 2007-07-03 03:18:28 EDT
Hi Satyabrata,

I've created a testing cert and uploaded these four result rpms there:
    http://hardware.redhat.com/hwcert/show.cgi?id=246577

And I didn't see any abnormal things. So could you please double check ?

Thanks
-YK
Comment 9 Satyabrata Maitra 2007-07-03 08:36:27 EDT
Hi YangKun
Actually when I am seeing the above URL on comment #8, I am seeing the
informations like below :-

New Hardware Certification Package Submitted
Kernel Version: kernel-2.6.18-8.el5

File Uploaded:
hts-IBM_ia64-ia64_server-Tikanga5_ia64_results-3.noarch.rpm
http://hardware.redhat.com/hwcert/data/rpms/76422a2a3dc575f3088ec4e5c3107d73/hts-IBM_ia64-ia64_server-Tikanga5_ia64_results-3.noarch.rpm

Please note the following failures:
WARNING: Kickstart file not found for required tests check.

0   FAILED   USB
    PASSED   INFO
1   PASSED   INFO
    PASSED   CORE
2   PASSED   INFO
    PASSED   MEMORY
3   PASSED   INFO
    FAILED   NETWORK
4   PASSED   INFO
    PASSED   STORAGE
5   PASSED   INFO
    FAILED   CDROM
6   FAILED   USB
    PASSED   INFO
7   PASSED   INFO
    PASSED   VIDEO

so, may I know why Network is showing FAILED? and what is these INFO? I dnt
wuite understand really. May u pls make me understand all these technical
terminologies for better understanding of hardware certification page pls?
Comment 10 YangKun 2007-07-03 21:49:09 EDT
Hi Satyabrata,

The NETWORK test failed because the "server-machine" was not working properly, 
we can see the following error from the output:
  "mount: 10.65.6.108:/var/hts/export failed, reason given by server: Permission
denied"

this maybe because the HTS-server-services were not started or maybe the
firewall was not configured properly . Please refer to the HTS docs on how to
configure the "Network Test Server" : /usr/share/hts/docs/s1-hts-network-server.html


"INFO" is a validation test, it will be run by default in every run(you may have
noticed the run numbers at the left-most side). The purpose of INFO test is to
collect the detailed system information and to check whether the system is a
"clean" RHEL5 environment, make sure the testing machine meets Hardware
Certification requiremnets(clean kernel, no 3rd party software or device drivers
been used , etc.). Only when the INFO test PASS, then the test results in the
same "run" can be valid.   


Please let me know if you have any other questions.

Also could you please confirm if we can close this bug now ;)

Thanks
-YK
Comment 11 Satyabrata Maitra 2007-07-13 07:52:31 EDT
Please close this bug as first of all, the network test for ia64, is PASS now,
and nothing abnormal here.

Note You need to log in before you can comment on or make changes to this bug.