Bug 244217 - Tray alerts do not work
Tray alerts do not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 11:43 EDT by Steve Fox
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 12:22:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Fox 2007-06-14 11:43:39 EDT
Description of problem:

No tray alert balloons when I receive private messages or highlighted messages.

Version-Release number of selected component (if applicable):

xchat-2.8.2-8.fc7

Steps to Reproduce:
1. Go into Preferences dialog
2. Go to Chatting->Alerts
3. Check 'Private Message' and 'Highlighted Message' in the 'Show tray ballons
on:' row.
4. Close dialog with OK and even try restarting Xchat

Actual results:

No alerts

Expected results:

balloons! (preferably shaped like a giraffe)

Additional info:

I'm guessing the alerts are implemented via libnotify and/or dbus. I have the
below packaged installed:

dbus-1.0.2-4.fc7
dbus-glib-devel-0.73-1.fc7
dbus-glib-0.73-1.fc7
dbus-python-0.80.2-3.fc7
dbus-devel-1.0.2-4.fc7
dbus-x11-1.0.2-4.fc7
libnotify-0.4.4-2.fc7
notify-python-0.1.0-4.fc7
pidgin-libnotify-0.12-7.fc7
Comment 1 Kevin Kofler 2007-06-14 22:07:14 EDT
Uh, I tried these and they worked here (even with the tray icon disabled, icon 
and baloons are apparently handled separately). Note that these (like all the 
other notifications you can enable) only show up when X-Chat is not the front 
window.
Comment 2 Kevin Kofler 2007-06-14 22:14:22 EDT
Uhm... Thinking of it, I tried these with the version I built myself outside of 
mock, it's possible that we're missing a BuildRequires. I'll check the build 
logs.
Comment 3 Kevin Kofler 2007-06-14 23:05:53 EDT
I just tested this with the official binary from updates now. I can't see any 
differences in the ldd output or in the build logs, but I redid the test anyway 
and it works for me (I get the tray balloons just fine).

dbus-1.0.2-4.fc7
dbus-glib-0.73-1.fc7
libnotify-0.4.4-2.fc7
notification-daemon-0.3.7-2.fc7

Running KDE 3.5.6 (kdebase-3.5.6-12.fc7), though that shouldn't matter.

Do you have notification-daemon running? (Try "pidof notification-daemon", that 
should output a number. If it outputs an empty string, you don't have it 
running.)
Comment 4 Steve Fox 2007-06-15 12:22:12 EDT
(In reply to comment #1)
> Uh, I tried these and they worked here (even with the tray icon disabled, icon 
> and baloons are apparently handled separately). Note that these (like all the 
> other notifications you can enable) only show up when X-Chat is not the front 
> window.

I wasn't aware of the focus issue. I have verified that it does indeed work when
X-Chat doesn't have focus. Thank you.
Comment 5 Christopher Aillon 2007-06-15 13:01:08 EDT
But are they shaped like giraffes?
Comment 6 Steve Fox 2007-06-15 16:16:05 EDT
I will submit an RFE for libnotify to add support.

Note You need to log in before you can comment on or make changes to this bug.